PKGBUILD 2.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. # Maintainer (arch): Felix Yan <felixonmars@archlinux.org>
  2. # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
  3. # Contributor: Andrea Scarpino <andrea@archlinux.org>
  4. # Maintainer: Andreas Grapentin <andreas@grapentin.org>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. # Contributor: jc_gargma <jc_gargma@iserlohn-fortress.net>
  7. # Contributor: SolveFinder <kwopleq@proton.me>
  8. # parabola changes and rationale:
  9. # - disable DRM
  10. pkgname=okular
  11. pkgver=24.05.0
  12. pkgrel=1
  13. pkgrel+=.parabola1
  14. pkgdesc='Document Viewer'
  15. pkgdesc+=', with copy-protection anti-feature disabled, without nonfree recommendations'
  16. arch=(x86_64)
  17. arch+=(i686 armv7h)
  18. url='https://apps.kde.org/okular/'
  19. # license=(GPL-2.0-or-later LGPL-2.0-or-later) # TODO:
  20. license=(GPL LGPL)
  21. depends=(discount
  22. djvulibre
  23. freetype2
  24. gcc-libs
  25. glibc
  26. plasma-activities
  27. karchive
  28. kbookmarks
  29. kcolorscheme
  30. kcompletion
  31. kconfig
  32. kconfigwidgets
  33. kcoreaddons
  34. kcrash
  35. ki18n
  36. kio
  37. kitemviews
  38. kparts
  39. kpty
  40. ktextwidgets
  41. kwallet
  42. kwidgetsaddons
  43. kwindowsystem
  44. kxmlgui
  45. libkexiv2
  46. libspectre
  47. libtiff
  48. phonon-qt6
  49. poppler-qt6
  50. purpose
  51. qt6-base
  52. qt6-declarative
  53. qt6-speech
  54. qt6-svg
  55. threadweaver
  56. zlib)
  57. makedepends=(ebook-tools
  58. extra-cmake-modules
  59. kdegraphics-mobipocket
  60. kdoctools)
  61. optdepends=('ebook-tools: mobi and epub support'
  62. 'kdegraphics-mobipocket: mobi support'
  63. 'unarchiver: Comic Book Archive support')
  64. groups=(kde-applications
  65. kde-graphics)
  66. source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
  67. source+=(disable-drm.patch)
  68. sha256sums=('6f322f78de2aa0a4079351fe4651c080bd98d27eeb7f9dcc37765271b4a3ac80'
  69. 'SKIP'
  70. '83cf760b3ae6e03d49e02369375dae3ecc05a6800d512dd9ffeaac1648c19457')
  71. validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
  72. F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
  73. D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
  74. options=(!zipman)
  75. prepare() {
  76. mkdir -p build
  77. cd $pkgname-$pkgver
  78. echo "applying disable-drm.patch"
  79. patch -Np1 -i "$srcdir"/disable-drm.patch
  80. }
  81. build() {
  82. cmake -B build -S $pkgname-$pkgver \
  83. -DBUILD_TESTING=OFF
  84. cmake --build build
  85. }
  86. package() {
  87. DESTDIR="$pkgdir" cmake --install build
  88. }