PKGBUILD 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Maintainer: Balló György <ballogyor+arch at gmail dot com>
  2. # Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
  3. pkgname=lxappearance-obconf-gtk3
  4. _pkgname=lxappearance-obconf
  5. pkgver=0.2.3
  6. pkgrel=3
  7. pkgrel+=.parabola1
  8. pkgdesc='Plugin for LXAppearance to configure Openbox (GTK+ 3 version)'
  9. arch=('i686' 'x86_64')
  10. license=('GPL2')
  11. url='https://lxde.org/'
  12. groups=('lxde-gtk3')
  13. depends=('lxappearance-gtk3' 'openbox' 'libobrender.so')
  14. makedepends=('intltool')
  15. conflicts=($_pkgname)
  16. source=(https://downloads.sourceforge.net/lxde/$_pkgname-$pkgver.tar.xz
  17. gtk3-theme-preview-hide.patch
  18. gtk3-theme-preview-segfault.patch)
  19. sha256sums=('3150b33b4b7beb71c1803aee2be21c94767d73b70dfc8d2bcaafe2650ea83149'
  20. '05a6bbea29468f85ebb1ccf0952688ecff53ac6f7b5fad58ae25ce540d698cf2'
  21. 'de9201ae495214d9f48669cadea043af6275484f341f01486c596e0cfcb90dd5')
  22. prepare() {
  23. cd $_pkgname-$pkgver
  24. # Hide theme preview, as it's broken with GTK+ 3
  25. # - https://sourceforge.net/p/lxde/bugs/768/
  26. patch -Np1 < "${srcdir}"/gtk3-theme-preview-hide.patch
  27. # Avoid rendering theme preview - GTK3/cairo segfault
  28. # - https://sourceforge.net/p/lxde/bugs/933/
  29. patch -Np1 < "${srcdir}"/gtk3-theme-preview-segfault.patch
  30. }
  31. build() {
  32. cd $_pkgname-$pkgver
  33. ./configure --prefix=/usr --enable-gtk3
  34. #https://bugzilla.gnome.org/show_bug.cgi?id=656231
  35. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  36. make
  37. }
  38. package() {
  39. cd $_pkgname-$pkgver
  40. make DESTDIR="$pkgdir" install
  41. }