12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849 |
- # Maintainer: bill-auger <bill-auger@programmer.net>
- # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
- # Contributor: Alexey Andreyev <aa13q@ya.ru>
- # Contributor Sefa Eyeoglu <contact@scrumplex.net>
- # parabola changes and rationale:
- # - the latest libquotient=0.9.x is apparently incompatible with 'quaternion'
- # this libre/libquotient exists temporarily, for only this reason
- # with the explicit provision 'libquotient=0.8.2'
- provides=( libquotient=0.8.2 )
- # - however, libquotient's other dependednt: 'itinerary' links to libquotient 0.9;
- # so this package must conflct with 'itinerary'
- conflicts=( itinerary=24.08.2-1 ) # FIXME: remove libre/libquotient eventually
- pkgname=libquotient
- pkgver=0.8.2
- pkgrel=1
- pkgrel+=.parabola1
- pkgdesc='A Qt library to write cross-platform clients for Matrix'
- license=(LGPL-2.1-or-later)
- arch=(x86_64)
- arch+=(armv7h i686)
- url='https://matrix.org/docs/projects/sdk/quotient'
- depends=(gcc-libs
- glibc
- libolm
- openssl
- qt6-base
- qtkeychain-qt6)
- makedepends=(cmake)
- source=(https://github.com/quotient-im/libQuotient/archive/$pkgver/$pkgname-$pkgver.tar.gz)
- sha256sums=('12ff2fa8b80a934b9dd88fa3416a4b88e94bc0e18a8df0dcebfc90614dd2f5c9')
- build() {
- cmake -B build -S libQuotient-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=None \
- -DBUILD_SHARED_LIBS=ON \
- -DBUILD_WITH_QT6=ON \
- -DQuotient_ENABLE_E2EE=ON
- cmake --build build
- }
- package() {
- DESTDIR="$pkgdir" cmake --install build
- }
|