PKGBUILD 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Maintainer: bill-auger <bill-auger@programmer.net>
  2. # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
  3. # Contributor: Alexey Andreyev <aa13q@ya.ru>
  4. # Contributor Sefa Eyeoglu <contact@scrumplex.net>
  5. # parabola changes and rationale:
  6. # - the latest libquotient=0.9.x is apparently incompatible with 'quaternion'
  7. # this libre/libquotient exists temporarily, for only this reason
  8. # with the explicit provision 'libquotient=0.8.2'
  9. provides=( libquotient=0.8.2 )
  10. # - however, libquotient's other dependednt: 'itinerary' links to libquotient 0.9;
  11. # so this package must conflct with 'itinerary'
  12. conflicts=( itinerary=24.08.2-1 ) # FIXME: remove libre/libquotient eventually
  13. pkgname=libquotient
  14. pkgver=0.8.2
  15. pkgrel=1
  16. pkgrel+=.parabola1
  17. pkgdesc='A Qt library to write cross-platform clients for Matrix'
  18. license=(LGPL-2.1-or-later)
  19. arch=(x86_64)
  20. arch+=(armv7h i686)
  21. url='https://matrix.org/docs/projects/sdk/quotient'
  22. depends=(gcc-libs
  23. glibc
  24. libolm
  25. openssl
  26. qt6-base
  27. qtkeychain-qt6)
  28. makedepends=(cmake)
  29. source=(https://github.com/quotient-im/libQuotient/archive/$pkgver/$pkgname-$pkgver.tar.gz)
  30. sha256sums=('12ff2fa8b80a934b9dd88fa3416a4b88e94bc0e18a8df0dcebfc90614dd2f5c9')
  31. build() {
  32. cmake -B build -S libQuotient-$pkgver \
  33. -DCMAKE_INSTALL_PREFIX=/usr \
  34. -DCMAKE_BUILD_TYPE=None \
  35. -DBUILD_SHARED_LIBS=ON \
  36. -DBUILD_WITH_QT6=ON \
  37. -DQuotient_ENABLE_E2EE=ON
  38. cmake --build build
  39. }
  40. package() {
  41. DESTDIR="$pkgdir" cmake --install build
  42. }