PKGBUILD 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. # Maintainer (arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
  2. # Maintainer (arch): Guillaume ALAUX <guillaume@archlinux.org>
  3. # Contributor: Andreas Radke <andyrtr@archlinux.org>
  4. # Maintainer: Isaac David <isacdaavid () isacdaavid!info>
  5. # Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
  6. # parabola changes and rationale:
  7. # - depending on iceweasel for building instead of firefox
  8. pkgbase=icedtea-web
  9. pkgname=('icedtea-web' 'icedtea-web-doc')
  10. pkgver=1.8.3
  11. pkgrel=1
  12. pkgrel+=.parabola1
  13. pkgdesc='Additional components for OpenJDK - Browser plug-in and Web Start implementation'
  14. pkgdesc+=', without nonfree firefox make dependency'
  15. url='https://github.com/AdoptOpenJDK/IcedTea-Web'
  16. arch=('x86_64')
  17. arch+=('i686' 'armv7h')
  18. license=('GPL2')
  19. makedepends=('java-environment=8' 'zip' 'libxtst' 'npapi-sdk' 'rhino' 'junit'
  20. 'iceweasel' 'epiphany' 'rust' 'bc')
  21. optdepends=('rhino: for using proxy auto config files')
  22. source=(https://github.com/AdoptOpenJDK/IcedTea-Web/archive/${pkgbase}-${pkgver}.tar.gz
  23. java13-SecurityManager.patch
  24. compiler-flags.patch)
  25. sha256sums=('41b6f09a7b44ad6b85d5086c289557f6f6340baa51be71bc4361aa26a844e7af'
  26. 'ee2221225afd4a577c1133b8ea4ddb7a596c7c8443cffc9185d21d404bd09f8c'
  27. '4db38a59012bf4c3dc857f340924ecbc796d89f15521abdc367bc39301be7a19')
  28. sha512sums=('878f2abffdce56ad487d495c68c70d07553a01ec379ab81b29dee4a9ddc34182337eb4b019d84dbe32160c9b9160ff2010e566cfa9beacf901bd5a14332a2c9e'
  29. '2ced4eb0542ed91a59d766bb4ca0db28a1f9b9569f48bf5b80ff178c81700067cc28a2ec99d06f479fa402ef4f290da291ad8275e52d1cbd27bee445e3ce3f7c'
  30. '0689abbe5fa5b616a3c71caf038a42bc69a4950e923cce3c658c15a85a140f5d2e19a96429fc82cfe38c42fdc7bca4a305fd613e3483a8f98a6ee3daaf0a8304')
  31. prepare() {
  32. cd IcedTea-Web-${pkgbase}-${pkgver}
  33. patch -Np0 < "${srcdir}/compiler-flags.patch"
  34. patch -Np1 < "${srcdir}/java13-SecurityManager.patch"
  35. autoreconf -fiv
  36. }
  37. build() {
  38. cd IcedTea-Web-${pkgbase}-${pkgver}
  39. ./configure \
  40. --prefix=/usr/share/${pkgbase} \
  41. --datarootdir=/usr/share \
  42. --with-jdk-home=/usr/lib/jvm/default \
  43. --with-jre-home=/usr/lib/jvm/default-runtime \
  44. --with-java=/usr/bin/java \
  45. --with-browser-tests \
  46. --with-firefox=/usr/bin/iceweasel \
  47. --with-epiphany=/usr/bin/epiphany \
  48. --with-itw-libs=DISTRIBUTION
  49. make
  50. }
  51. check() {
  52. cd IcedTea-Web-${pkgbase}-${pkgver}
  53. make -k check
  54. }
  55. package_icedtea-web() {
  56. depends=('java-runtime-openjdk' 'desktop-file-utils')
  57. provides=('java-web-start')
  58. cd IcedTea-Web-${pkgbase}-${pkgver}
  59. make DESTDIR="${pkgdir}" install
  60. # Install desktop files
  61. install -Dm 644 javaws.png -t "${pkgdir}"/usr/share/pixmaps
  62. install -Dm 644 *.desktop -t "${pkgdir}"/usr/share/applications
  63. ## link binaries into /usr/bin + jre/bin
  64. install -m 755 -d "${pkgdir}"/usr/bin
  65. for file in "${pkgdir}/usr/share/${pkgbase}/bin/"*; do
  66. ln -sf "/usr/share/${pkgbase}/bin/$(basename "${file}")" "${pkgdir}"/usr/bin
  67. done
  68. ## link the mozilla-plugin - test it here http://www.java.com/en/download/help/testvm.xml
  69. install -m 755 -d "${pkgdir}"/usr/lib/mozilla/plugins/
  70. ln -sf /usr/share/${pkgbase}/lib/IcedTeaPlugin.so "${pkgdir}"/usr/lib/mozilla/plugins/
  71. # remove splitted doc files
  72. rm -rf "${pkgdir}"/usr/share/doc
  73. }
  74. package_icedtea-web-doc() {
  75. pkgdesc+=' (documentation)'
  76. cd IcedTea-Web-${pkgbase}-${pkgver}
  77. make DESTDIR="${pkgdir}" install-data-local
  78. # remove javaws about and man page
  79. rm -rf "${pkgdir}"/usr/lib
  80. rm -rf "${pkgdir}"/usr/share/man
  81. rm -rf "${pkgdir}"/usr/share/icedtea-web
  82. }
  83. # vim: ts=2 sw=2 et: