PKGBUILD 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. # Maintainer (arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
  2. # Contributor: Jan de Groot <jgc@archlinux.org>
  3. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  4. # Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
  5. # Contributor: Iván Ávalos <avalos at disroot.org>
  6. # Contributor: André Silva <emulatorman@hyperbola.info>
  7. # Contributor: Márcio Silva <coadde@hyperbola.info>
  8. # parabola changes and rationale:
  9. # - rebranded to parabola
  10. # - switched default searchengine to duckduckgo
  11. # - removed useless dependency on icu because it's not
  12. # used at runtime according to readelf -d
  13. # - pin to sodeps
  14. # - disabled tests by default (require networking)
  15. pkgname=epiphany
  16. pkgver=43.1
  17. pkgrel=1
  18. pkgrel+=.parabola1
  19. pkgdesc="A GNOME web browser based on the WebKit rendering engine"
  20. url="https://wiki.gnome.org/Apps/Web"
  21. arch=(x86_64)
  22. arch+=(i686 armv7h)
  23. license=(GPL)
  24. depends=(
  25. gcr
  26. icu
  27. libarchive
  28. libdazzle
  29. libhandy
  30. libportal-gtk3
  31. libsoup3
  32. webkit2gtk-4.1
  33. )
  34. depends=( ${depends[*]/icu/} )
  35. depends+=(libhogweed.so)
  36. makedepends=(
  37. docbook-xml
  38. git
  39. gobject-introspection
  40. lsb-release
  41. meson
  42. startup-notification
  43. yelp-tools
  44. )
  45. checkdepends=(
  46. aspell
  47. hspell
  48. hunspell
  49. libvoikko
  50. nuspell
  51. xorg-server-xvfb
  52. )
  53. groups=(gnome)
  54. _commit=e21c2e68f34fcf23ca560088479e13c9929a4c36 # tags/43.1^0
  55. source=(
  56. "git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=$_commit"
  57. fix-test.diff
  58. )
  59. source+=(libre.patch)
  60. b2sums=('SKIP'
  61. '05121ff5f759ec637a718c9b39406f9a384227a312d69f6dc74e73fde8351689d588a30dddea3cfe0a6edb094fdcf5382eb5ff725bb2adfccdff87ab3cf4c953')
  62. b2sums+=('203dcf6e532aa4778662aab6ec7e4628d5ed05d4e22a3be5cf80ec9bc17610b650a4b8c2bed66337213aa2bf6a3ee7966f972aa2422571d75caf2f4ba792c6c8')
  63. _DISABLE_TESTS=1 # check() requires networking
  64. pkgver() {
  65. cd epiphany
  66. git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
  67. }
  68. prepare() {
  69. cd epiphany
  70. # Fix encoding test; perhaps caused by different glibc or locale env
  71. # https://gitlab.gnome.org/GNOME/epiphany/-/issues/1842
  72. git apply -3 ../fix-test.diff
  73. echo "applying libre.patch"
  74. patch -Np1 -i ../libre.patch
  75. }
  76. build() {
  77. arch-meson epiphany build
  78. meson compile -C build
  79. }
  80. check() {
  81. (( ! _DISABLE_TESTS )) || ! echo "skipping check()" || return 0
  82. dbus-run-session xvfb-run -s '-nolisten local' \
  83. meson test -C build --print-errorlogs
  84. }
  85. package() {
  86. meson install -C build --destdir "$pkgdir"
  87. }