PKGBUILD 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. # Maintainer (arch): Felix Yan <felixonmars@archlinux.org>
  2. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. pkgname=debootstrap
  7. pkgver=1.0.134
  8. pkgrel=1
  9. pkgrel+=.parabola2
  10. pkgdesc="Bootstrap a basic Trisquel system, without Debian support"
  11. arch=(any)
  12. license=(GPL)
  13. url="https://tracker.debian.org/pkg/debootstrap"
  14. depends=(wget binutils)
  15. makedepends=(git)
  16. source=("git+https://salsa.debian.org/installer-team/debootstrap.git#tag=${pkgver}"
  17. arch-detect.patch
  18. debootstrap.8)
  19. optdepends=('gnupg: check release signatures'
  20. 'pureos-archive-keyring: check PureOS release signatures'
  21. 'trisquel-keyring: check Trisquel release signatures')
  22. sha512sums=('SKIP'
  23. 'SKIP'
  24. 'SKIP')
  25. prepare() {
  26. cd debootstrap
  27. sed -i 's/sbin/bin/g' Makefile
  28. # gNewSense/Trisquel defaults
  29. sed -i 's|export PATH|export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"|' debootstrap
  30. # Detect Architecture
  31. patch -p1 -i ../arch-detect.patch
  32. # Remove Debian files
  33. rm -v debootstrap.8
  34. # Add rebranded man
  35. install -m644 ../debootstrap.8 .
  36. # Remove (non-FSDG compliant) distributions's scripts
  37. for SCRIPT in scripts/* ; do
  38. case $SCRIPT in
  39. scripts/amber) # PureOS 9.0
  40. ;;
  41. scripts/debian-common) # Required by debuerreotype
  42. ;;
  43. scripts/robur) # Trisquel 2.0
  44. ;;
  45. *)
  46. rm -v $SCRIPT
  47. ;;
  48. esac
  49. done
  50. # Enter to scripts dir
  51. cd scripts
  52. # Create PureOS symlinks
  53. ln -s amber byzantium # PureOS 10.0
  54. ln -s amber crimson # PureOS 11.0
  55. ln -s amber landing # Based on Debian testing
  56. # Create Trisquel symlinks
  57. ln -s robur dwyn # Trisquel 3.0
  58. ln -s robur awen # Trisquel 3.5
  59. ln -s robur taranis # Trisquel 4.0
  60. ln -s robur slaine # Trisquel 4.5
  61. ln -s robur dagda # Trisquel 5.0
  62. ln -s robur brigantia # Trisquel 5.5
  63. ln -s robur toutatis # Trisquel 6.0
  64. ln -s robur belenos # Trisquel 7.0
  65. ln -s robur flidas # Trisquel 8.0
  66. ln -s robur etiona # Trisquel 9.0
  67. ln -s robur nabia # Trisquel 10.0
  68. ln -s robur aramo # Trisquel 11.0
  69. }
  70. package() {
  71. cd debootstrap
  72. make DESTDIR="$pkgdir" install
  73. install -Dm644 debootstrap.8 "$pkgdir"/usr/share/man/man8/debootstrap.8
  74. }