123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104 |
- # Maintainer: David P. <megver83@parabola.nu>
- _target=arm-linux-gnueabi
- pkgname=$_target-gcc
- pkgver=12.2.0
- pkgrel=1
- #_snapshot=8-20210107
- pkgdesc='The GNU Compiler Collection - cross compiler for ARM GNU EABI little-endian target'
- arch=(x86_64 i686 armv7h)
- url='http://gcc.gnu.org/'
- license=(GPL LGPL FDL)
- depends=($_target-binutils libmpc zlib libisl zstd)
- makedepends=(gmp mpfr)
- options=(!emptydirs !strip !lto)
- source=(https://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig})
- #https://gcc.gnu.org/pub/gcc/snapshots/$_snapshot/gcc-$_snapshot.tar.xz
- sha512sums=('e9e857bd81bf7a370307d6848c81b2f5403db8c7b5207f54bce3f3faac3bde63445684092c2bc1a2427cddb6f7746496d9fbbef05fbbd77f2810b2998f1f9173'
- 'SKIP')
- validpgpkeys=(D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62 # Jakub Jelinek <jakub@redhat.com>
- 33C235A34C46AA3FFB293709A328C3A2C3C45C06 # Jakub Jelinek <jakub@redhat.com>
- 13975A70E63C361C73AE69EF6EEB81F8981C74C7) # Richard Guenther <richard.guenther@gmail.com>
- if [ -n "$_snapshot" ]; then
- _basedir=gcc-$_snapshot
- else
- _basedir=gcc-$pkgver
- fi
- prepare() {
- cd $_basedir
- echo $pkgver > gcc/BASE-VER
- mkdir $srcdir/gcc-build
- }
- build() {
- cd gcc-build
- # using -pipe causes spurious test-suite failures
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS=${CFLAGS/-pipe/}
- CXXFLAGS=${CXXFLAGS/-pipe/}
- # Credits @allanmcrae
- # https://github.com/allanmcrae/toolchain/blob/f18604d70c5933c31b51a320978711e4e6791cf1/gcc/PKGBUILD
- # TODO: properly deal with the build issues resulting from this
- CFLAGS=${CFLAGS/-Werror=format-security/}
- CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
- if [ "$CARCH" = i686 ]; then
- # using -Werror=format-security causes i686 build to fail
- CXXFLAGS+=' -Wno-error=format-security'
- fi
- $srcdir/$_basedir/configure \
- --target=$_target \
- --prefix=/usr \
- --libexecdir=/usr/lib \
- --enable-languages=c,c++ \
- --enable-plugins \
- --enable-shared \
- --disable-decimal-float \
- --disable-libffi \
- --disable-libgomp \
- --disable-libmudflap \
- --disable-libquadmath \
- --disable-libssp \
- --disable-libstdcxx-pch \
- --disable-nls \
- --disable-threads \
- --disable-tls \
- --disable-multilib \
- --with-gnu-as \
- --with-gnu-ld \
- --with-system-zlib \
- --with-gmp \
- --with-mpfr \
- --with-mpc \
- --with-isl \
- --with-libelf \
- --enable-gnu-indirect-function
- make all-gcc
- }
- package() {
- make -C gcc-build DESTDIR="$pkgdir" install-gcc
- # strip target binaries
- find "$pkgdir"/usr/lib/gcc/$_target/ \
- -type f -and \( -name \*.a -or -name \*.o \) \
- -exec $_target-objcopy -R .comment -R .note -R .debug_info -R .debug_aranges \
- -R .debug_pubnames -R .debug_pubtypes -R .debug_abbrev -R .debug_line \
- -R .debug_str -R .debug_ranges -R .debug_loc '{}' \;
- # strip host binaries
- find "$pkgdir/usr/bin/" "$pkgdir/usr/lib/gcc/$_target/" -type f \
- -and \( -executable \) -exec strip '{}' \;
- # Remove files that conflict with host gcc package
- rm -r "$pkgdir/usr/share/"{man/man7,info}
- }
|