PKGBUILD 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # SPDX-License-Identifier: CC0-1.0
  2. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  3. # NOTE: This PKGBUILD does not need to be edited manually.
  4. # The package is normally built automatically by the auto-builder.
  5. # To generate a new package, simply push changes to blacklist.git.
  6. # If ${pkgname}-blacklist.txt is modified, the auto-builder will
  7. # replace $pkgver, $_srcver, and the checksum (updpkgsums),
  8. # build and publish the package, and commit the changes to abslibre.
  9. pkgname=your-init-freedom
  10. pkgver=20221021
  11. pkgrel=1
  12. _srcver=249a8e38967abf9243252f03a4b33100cd636dbb
  13. pkgdesc="This meta-package conflicts with every package which strictly requires systemd"
  14. arch=(any)
  15. url=https://wiki.parabola.nu/Blacklist
  16. license=(custom:CCPL:zero)
  17. # license=('CCPL:zero') # TODO: NYI
  18. replaces=(your-initfreedom)
  19. makedepends=(librelib)
  20. install=${pkgname}.install
  21. _srcname=${pkgname}-blacklist-${_srcver}.txt
  22. source=(${_srcname}::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_srcver})
  23. sha256sums=('6dbe07d8f0fe38d90a1b6811ecfd2543f4638a94a36954256d3b6d1432768891')
  24. package()
  25. {
  26. # collect blacklisted package names as pacman conflicts
  27. conflicts=( $( libreblacklist normalize < ${_srcname} | \
  28. cut -d: -f1,2 | sed -n 's/:$//p' | sort -u ) )
  29. install -Dm644 ${_srcname} "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
  30. }