PKGBUILD 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Maintainer: David P. <megver83@parabola.nu>
  2. # Maintainer (Artix): Artoo <artoo@artixlinux.org>
  3. # Contributor (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
  4. # Contributor (Arch): Eli Schwartz <eschwartz@archlinux.org>
  5. # NOTE: Since Artix has multiple inits, they install ALPM hooks for
  6. # auto-detecting and setting the correct /usr/bin/init binary.
  7. # I've plans to add these to [nonsystemd] in the future.
  8. # Meanwhile, this package will set the default init to openrc-init.
  9. #_v=1.1
  10. #_url=https://gitea.artixlinux.org/artix/alpm-hooks
  11. pkgname=base
  12. pkgver=3
  13. pkgrel=1.parabola1.nonsystemd1
  14. pkgdesc='Minimal package set to define a basic Parabola GNU/Linux-libre installation'
  15. url='https://www.parabola.nu'
  16. arch=('x86_64' 'i686' 'armv7h')
  17. license=('GPL')
  18. optdepends=('linux-libre: bare metal support')
  19. #source=("alpm-hooks-$_v.tar.gz::$_url/archive/$_v.tar.gz")
  20. #sha256sums=('6d08e6853a7b66f5bcfb5df9c37428f410981ed8ca52f65e2923f8f74276f327')
  21. package() {
  22. depends=(
  23. # very very base
  24. 'filesystem' 'gcc-libs' 'glibc' 'bash'
  25. # POSIX tools
  26. 'coreutils' 'file' 'findutils' 'gawk' 'grep' 'procps-ng' 'sed' 'tar'
  27. # standard linux toolset
  28. 'gettext' 'pciutils' 'psmisc' 'shadow' 'util-linux' 'bzip2' 'gzip' 'xz'
  29. # distro defined requirements
  30. 'licenses' 'pacman' 'parabola-keyring' 'init-logind' 'esysusers' 'etmpfiles'
  31. 'your-freedom' 'your-init-freedom'
  32. # networking, ping, etc
  33. 'iputils' 'iproute2'
  34. )
  35. depends_x86_64=('archlinux-keyring')
  36. depends_i686=('archlinux32-keyring')
  37. depends_armv7h=('archlinuxarm-keyring')
  38. # pacman hooks
  39. #make -C alpm-hooks DESTDIR="${pkgdir}" install_base
  40. # provide default symlink for PM file tracking
  41. install -d "${pkgdir}"/usr/bin
  42. ln -svf openrc-init "${pkgdir}"/usr/bin/init
  43. }
  44. # vim: ts=2 sw=2 et: