PKGBUILD 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Maintainer (AUR) : tuftedocelot@fastmail.fm
  2. # Maintainer (AUR) : frank604 <frankshin82 at gmail>
  3. # Maintainer (AUR) : youngunix <zagazaw2004 'at' gmail 'dot' com>
  4. # Maintainer (AUR) : Jeremy L <jl AT adminempire DOT com>
  5. # Maintainer (Arch) : Alexander F Rødseth <xyproto@archlinux.org>
  6. # Contributor: Laurie Clark-Michalek <bluepeppers@archlinux.us>
  7. # Contributor: graysky <graysky AT archlinux DOR us>
  8. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  9. # Contributor: Aurélien Desbrières <aurelien@hackers.camp>
  10. # Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
  11. _pkgname=paraboley
  12. # FIXME: couldn't we skip the -git to simplify provides=() ?
  13. # we should probably use the one in [community] over AUR
  14. pkgname=${_pkgname}-git
  15. pkgver=9
  16. pkgrel=1
  17. pkgdesc="Python script to display system infomation alongside the Parabola GNU/Linux-libre logo."
  18. arch=('any')
  19. url="https://projects.parabola.nu/paraboley.git"
  20. license=('GPL')
  21. depends=('python')
  22. makedepends=('git' 'python-distribute')
  23. optdepends=(
  24. 'python-mpd-git: python libary for mpd interaction',
  25. 'python-logbook-git: for logging'
  26. 'imagemagick: for default screenshot command'
  27. )
  28. conflicts=('archey3')
  29. provides=('archey3' 'paraboley')
  30. replaces=('archey3')
  31. source=("git://projects.parabola.nu/paraboley.git")
  32. md5sums=('SKIP')
  33. pkgver() {
  34. cd ${_pkgname}
  35. git rev-list --count HEAD
  36. }
  37. package() {
  38. cd "$_pkgname"
  39. python setup.py install --root=${pkgdir}
  40. install -D -m644 COPYING ${pkgdir}/usr/share/licenses/paraboley/COPYING
  41. }