PKGBUILD 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Maintainer (arch): Vesa Kaihlavirta <vegai@iki.fi>
  2. # Contributor: André Silva <emulatorman@hyperbola.info>
  3. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  4. # Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  5. # parabola changes and rationale:
  6. # - removed recommendation for non-free openttd-opensfx
  7. # - depends on individual icu libraries to prevent upgrade breakages and
  8. # enable Parabola to provide older icu libraries in a separate package to
  9. # make transition easier for Parabola contributors. See the comments in
  10. # the icu-*-compat PKGBUILDs for more details.
  11. pkgname=openttd
  12. pkgver=13.4
  13. pkgrel=2
  14. pkgrel+=.parabola1
  15. pkgdesc='Engine for running Transport Tycoon Deluxe'
  16. arch=(x86_64)
  17. arch+=(i686 armv7h)
  18. url='https://www.openttd.org'
  19. license=(GPL)
  20. depends=(fluidsynth fontconfig hicolor-icon-theme)
  21. depends+=('libicui18n.so' 'libicuuc.so')
  22. makedepends=(cmake ninja)
  23. optdepends=('openttd-opengfx: free graphics')
  24. source=("https://cdn.$pkgname.org/$pkgname-releases/$pkgver/$pkgname-$pkgver-source.tar.xz")
  25. b2sums=('0ef635e40fe47185168bd13e4b8ce24a8ff9c4afe3eced6197298986127ee196a6dcb379643bbb1de9bb552e71cda5df5b5b35006ed2b43d6e33e8513b1cd550')
  26. build() {
  27. # http://site.icu-project.org/download/61#TOC-Migration-Issues
  28. CXXFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
  29. cmake \
  30. -B build \
  31. -D CMAKE_BUILD_TYPE=Release \
  32. -D CMAKE_INSTALL_BINDIR=bin \
  33. -D CMAKE_INSTALL_DATADIR=/usr/share \
  34. -D CMAKE_INSTALL_PREFIX=/usr \
  35. -G Ninja \
  36. -S $pkgname-$pkgver
  37. ninja -C build
  38. }
  39. package() {
  40. DESTDIR="$pkgdir" ninja -C build install
  41. }