PKGBUILD 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Maintainer (arch): Maxime Gauduin <alucryd@archlinux.org>
  2. # Contributor: mortzu <me@mortzu.de>
  3. # Contributor: fnord0 <fnord0@riseup.net>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # Contributor: Márcio Silva <coadde@hyperbola.info>
  6. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  7. # parabola changes and rationale:
  8. # - no significant change - re-package for linux-libre
  9. # - pin to kernel versions
  10. # build order:
  11. # acpi_call-dkms <- acpi_call-lts
  12. # acpi_call
  13. # linux-libre-lts-headers <- acpi_call-lts
  14. # tp_smapi-lts
  15. # linux-libre-headers <- acpi_call
  16. # tp_smapi
  17. #
  18. # NOTE: It is normally not necessary to edit any of these PKGBUILDs.
  19. # These packages may be built as a batch, with the helper script:
  20. # 'scripts/package-all-acpi_call-tp_smapi'
  21. # Simply edit 'KERNEL_VER' and/or 'KERNEL_LTS_VER' in the helper script.
  22. # It will build any or all of the above packages,
  23. # but only those for which the PKGBUILD '_basekernel' differs,
  24. # update '_basekernel', and commit the changes to VCS, if successful.
  25. _basekernel=6.7.4
  26. pkgname=acpi_call-dkms
  27. _tag='9f1c0b5d046bdfdec769809435257647fd475473' # git rev-parse v${_tag_name}
  28. pkgver=1.2.2
  29. pkgrel=1
  30. pkgrel+=.parabola1.basekernel${_basekernel}
  31. pkgdesc='A linux kernel module that enables calls to ACPI methods through /proc/acpi/call - module sources'
  32. pkgdesc+=" (for 'linux-libre')"
  33. url='https://github.com/nix-community/acpi_call'
  34. arch=('any')
  35. arch=('armv7h' 'i686' 'x86_64') # just to simplify the package-all-acpi_call-tp_smapi script
  36. license=('GPL')
  37. depends=('dkms')
  38. makedepends=('git')
  39. provides=("acpi_call=${pkgver}-${pkgrel%%.*}")
  40. conflicts=('acpi_call')
  41. source=("git+https://github.com/nix-community/acpi_call.git#tag=${_tag}"
  42. 'dkms.conf')
  43. b2sums=('SKIP'
  44. '504da1102e778fe54368e990408dbef02f5b2ce91f683d170f3d6a1a2f9349d00d61dcbddd0262a8dfc958ea0964135ba58d8dd88ac06bd10b5e13b90f11faef')
  45. package() {
  46. install -D -m0644 acpi_call/{Makefile,acpi_call.c} dkms.conf -t "${pkgdir}"/usr/src/acpi_call-${pkgver}
  47. echo acpi_call | install -D -m0644 /dev/stdin "${pkgdir}"/usr/lib/modules-load.d/acpi_call.conf
  48. install -d -m0755 "${pkgdir}"/usr/share/acpi_call
  49. cp -dr --no-preserve=ownership acpi_call/{examples,support} "${pkgdir}"/usr/share/acpi_call/
  50. }