PKGBUILD 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283
  1. # Maintainer (arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
  2. # Maintainer (arch): Morten Linderud <foxboron@archlinux.org>
  3. # Maintainer (archarm): Kevin Mihelich <kevin@archlinuxarm.org>
  4. # Maintainer: Luke T. Shumaker <lukeshu@parabola.nu>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. # Contributor: Márcio Silva <coadde@hyperbola.info>
  7. # Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
  8. # Contributor: Nicolás Reynolds <fauno@kiwwwi.com.ar>
  9. # Contributor: Daniel Milewski <niitotantei@riseup.net>
  10. # Contributor: bill-auger <bill-auger@programmer.net>
  11. # ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
  12. # - arch/host/flags for armv7h, and aarch64
  13. # - pacman.conf: architecture=armv7h/aarch64, added our aur and alarm repos
  14. # - makepkg.conf: adjusted C/CXX/LDFLAGS
  15. # - patch to sync filesystem after install/remove
  16. # - reverts to allow scriplet input on stdin
  17. # - patch to fix application/gzip change in file 5.37
  18. # Parabola:
  19. # - pacman.conf, makepkg.conf: Provide the default files for all
  20. # architectures.
  21. # - makepkg: Allow "${X}.parabola${Y}" pkgrel values
  22. # - pacman-key: Always regenerate GPG trust DB per `pacman-key --updatedb`,
  23. # which can help to maintain sanity (new/expired keys, rapid churn, etc).
  24. pkgname=pacman
  25. pkgver=7.0.0.r3.g7736133
  26. pkgrel=1
  27. pkgrel+=.parabola1
  28. # use annotated tag and patch level commit from release branch (can be empty for no patches)
  29. _git_tag=7.0.0
  30. _git_patch_level_commit=77361331ae3864c6ea880e715c5864d59336f275
  31. pkgdesc="A library-based package manager with dependency support"
  32. arch=('x86_64')
  33. arch+=('armv7h' 'i686')
  34. url="https://www.archlinux.org/pacman/"
  35. license=('GPL-2.0-or-later')
  36. depends=(
  37. bash
  38. coreutils
  39. curl
  40. gawk
  41. gettext
  42. glibc
  43. gnupg
  44. gpgme
  45. grep
  46. libarchive
  47. pacman-mirrorlist
  48. systemd
  49. )
  50. makedepends=(
  51. asciidoc
  52. doxygen
  53. git
  54. meson
  55. )
  56. checkdepends=(
  57. fakechroot
  58. python
  59. )
  60. optdepends=(
  61. 'base-devel: required to use makepkg'
  62. 'perl-locale-gettext: translation support in makepkg-template'
  63. )
  64. provides=('libalpm.so')
  65. backup=(etc/pacman.conf
  66. etc/makepkg.conf
  67. etc/makepkg.conf.d/rust.conf)
  68. validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
  69. 'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
  70. source=("git+https://gitlab.archlinux.org/pacman/pacman.git#tag=v${_git_tag}?signed"
  71. revertme-makepkg-remove-libdepends-and-libprovides.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/354a300cd26bb1c7e6551473596be5ecced921de.patch
  72. pacman.conf
  73. makepkg.conf
  74. alpm.sysusers
  75. rust.conf)
  76. source=(${source[@]/pacman.conf/"${arch[@]/#/pacman.conf.}"}) # Parabola: pacman.conf -> pacman.conf.{armv7h,i686,x86_64}
  77. source=("${source[@]/makepkg.conf/makepkg.conf.in}") # Parabola: makepkg.conf -> makepkg.conf.in
  78. source+=(9001-makepkg-Treat-pkgrel-more-similarly-to-pkgver.patch
  79. 9002-pacman-key-updatedb.patch)
  80. source_armv7h=(arm-0001-Sychronize-filesystem.patch
  81. arm-0002-Revert-close-stdin-before-running-install-scripts.patch
  82. arm-0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch)
  83. sha256sums=('06d082c3ce6f0811ca728515aa82d69d372800bd3ada99f5c445ef9429b6e3a6'
  84. 'b3bce9d662e189e8e49013b818f255d08494a57e13fc264625f852f087d3def2'
  85. '94ba39177f80b258696ce5a5a468f0bc3a538c961ae013b84f54b6cfad986624' # DIFF: should differ from arch (pacman.conf.x86_64)
  86. 'e73fab040e3b5d5e849a1d3eb64421a17c96cbdbbc2c5d9a465ab129435107de' # DIFF: should differ from arch (pacman.conf.armv7h)
  87. 'b6acea271bb38f25376eb28f08fc55cf18c1ec3c47c7a0c19ad1ed0ffe753eef' # DIFF: should differ from arch (pacman.conf.i686 )
  88. '72c606c676252b72fcaab5ac3aa057332d748e1930200c7fa95c73e09208d898' # DIFF: should differ from arch (makepkg.conf)
  89. '8c12bfb5af83a1a6ae48dabaa3a92fed0fc28ad46df1cd5cac848923586408a7' # DIFF: should differ from arch (naming confusion)
  90. '59a8bbdc32830c90dbce5ead9f90074a2bb31cd85ec92bc5f92251bb4bcf8a1d')
  91. sha256sums+=('9ccc7ef5bd27a68d8788f10c6e5b36495c5d9038d4eb160f9ea4dc9901b622d8'
  92. '39e4db3eed5dc522baffb7f853a7dbb7b417cc7a718599d768297adfbe99e263')
  93. sha256sums_armv7h=('8d70fb5094f58aad98b601bbc42be354c2014b9fe734a1ee0b1e14bb041cc9cc'
  94. '0e771370da68c855bfb4eaad4c2ae137883a474886a049b934dac2e775574cb9'
  95. '2f586f72c34150330389854575a21be1d3ef3637c4f94bec2e948c2717a5aecb')
  96. pkgver() {
  97. cd "$pkgname"
  98. git describe --abbrev=7 --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
  99. }
  100. prepare() {
  101. cd "$pkgname"
  102. # apply patch level commits on top of annotated tag
  103. if [[ -n ${_git_patch_level_commit} ]]; then
  104. if [[ v${_git_tag} != $(git describe --tags --abbrev=0 "${_git_patch_level_commit}") ]] then
  105. error "patch level commit ${_git_patch_level_commit} is not a descendant of v${_git_tag}"
  106. exit 1
  107. fi
  108. git rebase "${_git_patch_level_commit}"
  109. fi
  110. # handle patches
  111. local -a patches
  112. patches=($(printf '%s\n' "${source[@]}" | grep '.patch'))
  113. patches=("${patches[@]%%::*}")
  114. patches=("${patches[@]##*/}")
  115. if (( ${#patches[@]} != 0 )); then
  116. for patch in "${patches[@]}"; do
  117. if [[ $patch =~ revertme-* ]]; then
  118. msg2 "Reverting patch $patch..."
  119. patch -RNp1 < "../$patch"
  120. else
  121. msg2 "Applying patch $patch..."
  122. patch -Np1 < "../$patch"
  123. fi
  124. done
  125. fi
  126. ## Parabola changes ##
  127. # Generate a "makepkg.conf.${carch}" file for each "${arch[@]}".
  128. local carch chost cflags ldflags
  129. local cxxflags ltoflags rustflags dbgflags dbgrustflags options libdirs
  130. for carch in "${arch[@]}"; do
  131. # Base definitions. Each architecture must still set `chost`,
  132. # `cflags`, and `ldflags`; and may modify these base definitions.
  133. cxxflags='$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS'
  134. ltoflags='-flto=auto'
  135. rustflags='-Cforce-frame-pointers=yes'
  136. dbgflags='-g'
  137. dbgrustflags='-C debuginfo=2'
  138. options=(strip docs !libtool !staticlibs emptydirs zipman purge debug lto)
  139. libdirs=('lib:usr/lib')
  140. zstdflags=(-T0 --ultra -20)
  141. case "$carch" in
  142. armv7h)
  143. chost='armv7l-unknown-linux-gnueabihf'
  144. # ALARM includes '-mno-omit-leaf-frame-pointer' in CFLAGS in
  145. # their pacman-6.1.0-3-armv7h.pkg.tar.xz, even though that
  146. # flag doesn't exist on armv7h (as of
  147. # gcc-14.1.1+r1+g43b730b9134-1-armv7h.pkg.tar.xz). So I guess
  148. # ALARM is just shipping a broken makepkg.conf?
  149. cflags='-march=armv7-a -mfloat-abi=hard -mfpu=neon -O2 -pipe -fstack-protector-strong -fno-plt -fexceptions \
  150. -Wp,-D_FORTIFY_SOURCE=3 -Wformat -Werror=format-security \
  151. -fstack-clash-protection \
  152. -fno-omit-frame-pointer'
  153. # ALARM includes '-Wl,-z,pack-relative-relocs' in LDFLAGS in
  154. # their pacman-6.1.0-3-armv7h.pkg.tar.xz, even though that
  155. # flag is x86- (and ppc64-?) -only. Depending on how the
  156. # compiler is called, that may result in a harmless warning on
  157. # stderr, or it may result in the compiler failing.
  158. ldflags='-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now'
  159. # overrides
  160. ltoflags=""
  161. rustflags=""
  162. dbgrustflags=""
  163. options=("${options[@]/#lto/!lto}") # disable lto
  164. zstdflags=(--single-thread) # optimize for memory use
  165. ;;
  166. i686)
  167. chost='i686-pc-linux-gnu'
  168. cflags='-march=i686 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
  169. -Wp,-D_FORTIFY_SOURCE=3 -Wformat -Werror=format-security \
  170. -fstack-clash-protection -fcf-protection \
  171. -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer'
  172. ldflags='-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now \
  173. -Wl,-z,pack-relative-relocs'
  174. ;;
  175. x86_64)
  176. chost='x86_64-pc-linux-gnu'
  177. cflags='-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
  178. -Wp,-D_FORTIFY_SOURCE=3 -Wformat -Werror=format-security \
  179. -fstack-clash-protection -fcf-protection \
  180. -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer'
  181. ldflags='-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now \
  182. -Wl,-z,pack-relative-relocs'
  183. # overrides
  184. libdirs+=('lib32:usr/lib32')
  185. ;;
  186. esac
  187. sed < "${srcdir}"/makepkg.conf.in > "${srcdir}/makepkg.conf.${carch}" \
  188. -e "s|@CARCH@|${carch}|g" \
  189. -e "s|@CHOST@|${chost}|g" \
  190. -e "s|@CFLAGS@|${cflags//'\'/'\\\'}|g" \
  191. -e "s|@CXXFLAGS@|${cxxflags//'\'/'\\\'}|g" \
  192. -e "s|@LDFLAGS@|${ldflags//'\'/'\\\'}|g" \
  193. -e "s|@LTOFLAGS@|${ltoflags//'\'/'\\\'}|g" \
  194. -e "s|@RUSTFLAGS@|${rustflags//'\'/'\\\'}|g" \
  195. -e "s|@DBGFLAGS@|${dbgflags//'\'/'\\\'}|g" \
  196. -e "s|@DBGRUSTFLAGS@|${dbgrustflags//'\'/'\\\'}|g" \
  197. -e "s|@OPTIONS@|${options[*]}|g" \
  198. -e "s|@LIBDIRS@|${libdirs[*]@Q}|g" \
  199. -e "s|@ZSTDFLAGS@|${zstdflags[*]}|g"
  200. done
  201. # Put the files for this arch at a neutral location.
  202. cp -T "${srcdir}/pacman.conf.${CARCH}" "${srcdir}"/pacman.conf
  203. cp -T "${srcdir}/makepkg.conf.${CARCH}" "${srcdir}"/makepkg.conf
  204. }
  205. build() {
  206. cd "$pkgname"
  207. meson --prefix=/usr \
  208. --buildtype=plain \
  209. -Ddoc=enabled \
  210. -Ddoxygen=enabled \
  211. -Dscriptlet-shell=/usr/bin/bash \
  212. -Dldconfig=/usr/bin/ldconfig \
  213. build
  214. meson compile -C build
  215. }
  216. check() {
  217. cd "$pkgname"
  218. meson test -C build
  219. }
  220. package() {
  221. cd "$pkgname"
  222. DESTDIR="$pkgdir" meson install -C build
  223. # install Arch specific stuff
  224. install -dm755 "$pkgdir/etc"
  225. install -m644 "$srcdir/pacman.conf" "$pkgdir/etc"
  226. install -m644 "$srcdir/makepkg.conf" "$pkgdir/etc"
  227. install -D -m644 "$srcdir/alpm.sysusers" "${pkgdir}"/usr/lib/sysusers.d/alpm.conf
  228. install -m644 "$srcdir/rust.conf" "$pkgdir/etc/makepkg.conf.d"
  229. local wantsdir="$pkgdir/usr/lib/systemd/system/sockets.target.wants"
  230. install -dm755 "$wantsdir"
  231. local unit
  232. for unit in dirmngr gpg-agent gpg-agent-{browser,extra,ssh} keyboxd; do
  233. ln -s "../${unit}@.socket" "$wantsdir/${unit}@etc-pacman.d-gnupg.socket"
  234. done
  235. ## install Parabola specific stuff ##
  236. # per-arch pacman.conf(s) and makepkg.conf(s)
  237. local carch
  238. for carch in "${arch[@]}"; do
  239. install -D -m644 -t "$pkgdir/usr/share/pacman/defaults/" "$srcdir/pacman.conf.$carch"
  240. install -D -m644 -t "$pkgdir/usr/share/pacman/defaults/" "$srcdir/makepkg.conf.$carch"
  241. done
  242. }