PKGBUILD 854 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright (C) 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  2. # This program is free software: you can redistribute it and/or modify
  3. # it under the terms of the CC0 1.0 License.
  4. # Maintainer: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  5. # Note that this software works but it's not completely ready for
  6. # public usage yet.
  7. pkgname=public-archive
  8. pkgver=0.0.2
  9. pkgrel=1
  10. pkgdesc="Various scripts that don't fit elsewhere"
  11. arch=('any')
  12. url='https://git.sr.ht/~gnutoo/public-archive'
  13. license=('GPL3')
  14. makedepends=('autoconf'
  15. 'automake'
  16. 'git'
  17. 'gcc-go')
  18. source=("git+https://git.sr.ht/~gnutoo/public-archive/#commit=v${pkgver}")
  19. sha512sums=('SKIP')
  20. build(){
  21. cd ${pkgname}
  22. ./autogen.sh
  23. ./configure --prefix=/usr
  24. make
  25. }
  26. package(){
  27. cd ${pkgname}
  28. make install DESTDIR="${pkgdir}"
  29. }