PKGBUILD 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. # Maintainer: David P. <megver83@parabola.nu>
  3. # Contributor: Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
  4. # Contributor: fauno <fauno@kiwwwi.com.ar>
  5. # Contributor: Márcio Silva <coadde@hyperbola.info>
  6. # Contributor: bill-auger <bill-auger@programmer.net>
  7. pkgbase=libretools
  8. pkgname=(libretools librelib gitget)
  9. pkgver=20190907
  10. _pacman_constraints=( 'pacman<6.2' )
  11. pkgrel=1
  12. pkgrel+=.nonsystemd3
  13. pkgdesc="Programs for Parabola development"
  14. arch=('any')
  15. url="https://git.parabola.nu/packages/libretools.git/"
  16. # license=(GPL-2.0-only GPL-3.0-or-later) # TODO:
  17. license=('GPL2' 'GPL3')
  18. makedepends=(ruby-ronn-ng)
  19. checkdepends=(
  20. bats
  21. git
  22. "${_pacman_constraints[@]}"
  23. expac
  24. openssh
  25. rsync
  26. tokyocabinet
  27. )
  28. source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver-nonsystemd.tar.gz{,.sig})
  29. source+=(0001-revert.patch
  30. 0002-libremakepkg-pacman_5_2.patch)
  31. sha256sums=('c9bdc6f422234b6b260349e488266500756857bbb65079783aa5e997b6a2d410'
  32. 'SKIP')
  33. sha256sums+=('108aa8bbfb1ffe96427540cd8f7788338883b08ad038b2ed426e93ac6c57e91b'
  34. '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
  35. validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
  36. '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
  37. 'BFA8008A8265677063B11BF47171986E4B745536' # Andreas Grapentin
  38. '3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40') # bill-auger
  39. prepare() {
  40. cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
  41. patch -N -p1 -i $srcdir/revert.patch
  42. patch -N -p1 -i $srcdir/0002-libremakepkg-pacman_5_2.patch
  43. }
  44. build() {
  45. cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
  46. make
  47. }
  48. check() {
  49. cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
  50. # <= 20240327
  51. # SUDO_USER= make check TESTENVFLAGS='--no-network --no-sudo'
  52. # >= 20240403
  53. # SUDO_USER= make check BATS_FLAGS='--filter-tags !network,!sudo'
  54. }
  55. package_librelib() {
  56. pkgdesc="The shell library portion of libretools"
  57. license=(GPL2)
  58. conflicts=('xbs')
  59. optdepends=(
  60. 'libretools: for libreblacklist/blacklist.sh'
  61. 'wget: for libreblacklist/blacklist.sh'
  62. )
  63. cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
  64. make install-librelib DESTDIR="$pkgdir"
  65. }
  66. package_gitget() {
  67. pkgdesc="A simple to use downloader for git URLs"
  68. license=(GPL2)
  69. depends=("librelib=$pkgver" git)
  70. cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
  71. make install-gitget DESTDIR="$pkgdir"
  72. }
  73. package_libretools() {
  74. backup=(etc/libretools.conf
  75. etc/libretools.d/chroot.conf
  76. etc/libretools.d/libredbdiff.conf
  77. etc/libretools.d/librefetch.conf)
  78. install=libretools.install
  79. conflicts=(devtools)
  80. depends=(
  81. arch-install-scripts # `mkarchroot` uses `pacstrap`
  82. binutils # `libremakepkg`->`makepkg` uses `strip`
  83. expac # `libredbdiff`
  84. fakeroot # `libremakepkg`->`makepkg` uses `fakeroot`
  85. make # `librefetch`
  86. openssh # `librerelease`
  87. pacutils # `librechroot` uses `pacsift`
  88. rsync # `librerelease` and `makechrootpkg.sh`
  89. tokyocabinet # `toru`
  90. namcap # `libremakepkg`
  91. subversion # `diff-unfree`
  92. wget # `aur`, optdepend for librelib:`blacklist`
  93. )
  94. depends+=( # pinned dependencies
  95. "librelib=$pkgver"
  96. "gitget=$pkgver" # `createworkdir`
  97. "${_pacman_constraints[@]}"
  98. )
  99. depends=( ${depends[*]/pacutils/} ) # WIP
  100. depends=( ${depends[*]/namcap/} ) # FIXME: Namcap is currently disabled in libremakepkg :-(
  101. optdepends=(
  102. 'qemu-user-static-binfmt: To build ARM packages from x86'
  103. )
  104. cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
  105. make install-libretools DESTDIR="$pkgdir"
  106. }