PKGBUILD 770 B

12345678910111213141516171819202122232425
  1. # Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
  2. _pkgname=bencode
  3. pkgname=python2-bencode
  4. pkgver=1.0
  5. pkgdesc="BitTorrent bencode module as leight-weight, standalone package"
  6. url="http://pypi.python.org/pypi/BitTorrent-bencode"
  7. license=('custom:BitTorrent Open Source License')
  8. pkgrel=1
  9. arch=('any')
  10. depends=('python2')
  11. makedepends=('python2-distribute')
  12. source=(http://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz
  13. bittorrent-osl.txt)
  14. package(){
  15. cd "$srcdir/$_pkgname-$pkgver"
  16. python2 setup.py install --root="$pkgdir" --optimize=1
  17. install -Dm644 "$srcdir"/bittorrent-osl.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
  18. }
  19. md5sums=('400dd42ff346eb7db91245403f8f2b7b'
  20. '016d959cb9f7a319e48d9699c4ef2f42')