PKGBUILD 4.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. # Contributor: aimileus <me at aimileus dot nl>
  2. # Maintainer: Fabio 'Lolix' Loli <lolix at disroot.org>
  3. # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
  4. # Contributor: Andreas Schönfelder <passtschu at freenet dot de>
  5. pkgname=phoronix-test-suite
  6. pkgver=9.2.1
  7. pkgrel=1
  8. pkgrel+=.par1
  9. pkgdesc="The most comprehensive testing and benchmarking platform available for Linux without the nonfree tests"
  10. arch=(any)
  11. license=(GPL3)
  12. url="http://www.phoronix-test-suite.com/"
  13. depends=(php)
  14. optdepends=('php-gd'
  15. 'sqlite3: required when running a Phoromatic server.'
  16. 'gcc-fortran: required for universe-cli test suite'
  17. 'blas: required for universe-cli test suite'
  18. 'lapack: required for universe-cli test suite'
  19. 'portaudio: required for universe-cli test suite'
  20. 'unzip: required for universe-cli test suite'
  21. 'mesa-demos: required for universe-cli test suite'
  22. 'openmpi: required for universe-cli test suite')
  23. source=("$pkgname-$pkgver.tar.gz::https://github.com/phoronix-test-suite/phoronix-test-suite/archive/v${pkgver}.tar.gz"
  24. "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/phoronix-test-suite-launcher.patch"
  25. "0001-Don-t-download-online-tests.patch")
  26. sha256sums=('28acbcb6c5b8eb27c20329cd1a5ea3f1a27abb69812c4b1eeade4b91c89fc7d8'
  27. '577326343d0303a59fd469c3f9c9740e756dd59c0660c54363b62d6fd1cee26d'
  28. 'SKIP')
  29. options=(!strip)
  30. test_profiles=('build-apache-1.5.1'
  31. 'build-eigen-1.0.0'
  32. 'build-gcc-1.1.2'
  33. 'build-llvm-1.1.0'
  34. 'build-php-1.4.0')
  35. # Issues:
  36. # build-firefox: source code not FSDG compliant
  37. # build-imagemagick: TODO: rebuild the tarball from official source code
  38. # build-linux-kernel: source code not FSDG compliant
  39. # build-mplayer: TODO: make sure that it doesn't build with FAAC
  40. # build-webkitfltk: TODO: review the project source code
  41. prepare() {
  42. cd "$srcdir/$pkgname-$pkgver"
  43. patch phoronix-test-suite -i "${srcdir}/phoronix-test-suite-launcher.patch"
  44. patch -p1 -i "${srcdir}/0001-Don-t-download-online-tests.patch"
  45. # Only keep tests that meet the following requirements:
  46. # - No dependencies on nonfree software
  47. # - No binaries
  48. # - Source comming from official projects potentially with additional patches
  49. # to be able to understand what was changed.
  50. mkdir -p ob-cache_/test-profiles/pts/
  51. for p in ${test_profiles[@]} ; do
  52. # Local works with the current patch
  53. # TODO: make it appear under pts
  54. mv ob-cache/test-profiles/pts/${p} ob-cache_/test-profiles/local/
  55. done
  56. rm -rf ob-cache
  57. mv ob-cache_ ob-cache
  58. }
  59. package() {
  60. cd "$srcdir/$pkgname-$pkgver"
  61. ./install-sh $pkgdir/usr
  62. rm -r "${pkgdir}"/usr/share/phoronix-test-suite/deploy
  63. rm -rf "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/{dependency-handlers,scripts,xml}/{*.php,*.sh,*.xml}
  64. install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/dependency-handlers/arch_dependency_handler.php \
  65. "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/dependency-handlers/arch_dependency_handler.php
  66. install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/scripts/install-arch-packages.sh \
  67. "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/scripts/install-arch-packages.sh
  68. install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/xml/arch-packages.xml \
  69. "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/xml/arch-packages.xml
  70. install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/xml/generic-packages.xml \
  71. "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/xml/generic-packages.xml
  72. install "${srcdir}/phoronix-test-suite-${pkgver}"/phoronix-test-suite \
  73. "${pkgdir}"/usr/bin/phoronix-test-suite
  74. ln -s /usr/bin/phoronix-test-suite "$pkgdir/usr/bin/pts"
  75. }