PKGBUILD 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. # Contributor: Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
  3. # Contributor: fauno <fauno@kiwwwi.com.ar>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. # Contributor: bill-auger <bill-auger@programmer.net>
  6. # Upstream information
  7. pkgbase=libretools
  8. pkgname=(libretools librelib gitget)
  9. pkgdesc="Programs for Parabola development"
  10. url="https://git.parabola.nu/packages/libretools.git/"
  11. license=(GPL-2.0-only GPL-3.0-or-later)
  12. pkgver=20240707
  13. source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig}
  14. test-rubygems.rb)
  15. sha256sums=('b3e22601e85a28de2693b6a2894079127bba3dbf69a837d978e125e0ca989243'
  16. 'SKIP'
  17. '649abdfe296768077ae62b3534d73fda67b0ade94983823c7d4a539b986b828b')
  18. validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
  19. '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
  20. 'BFA8008A8265677063B11BF47171986E4B745536' # Andreas Grapentin
  21. '3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40') # bill-auger
  22. # Package information
  23. pkgrel=2
  24. arch=('any')
  25. makedepends=(ruby-ronn-ng)
  26. _pacman_constraints=('pacman>=7.0' 'pacman<7.1')
  27. checkdepends=(
  28. bats-assert
  29. bats-file
  30. git
  31. "${_pacman_constraints[@]}"
  32. expac
  33. openssh
  34. rsync
  35. tokyocabinet
  36. )
  37. # Build instructions
  38. build() {
  39. if ! ./test-rubygems.rb
  40. then echo "\`rubygems\` seems to be broken again - man pages will not be built"
  41. sed -i 's|^enable_manpages = .*|enable_manpages =|' $pkgbase-$pkgver/config.mk
  42. fi
  43. cd "$srcdir/$pkgbase-$pkgver"
  44. make
  45. }
  46. check() {
  47. cd "$srcdir/$pkgbase-$pkgver"
  48. SUDO_USER= make check BATS_FLAGS='--filter-tags !network,!sudo,!btrfs,!locale-es'
  49. }
  50. package_librelib() {
  51. pkgdesc="The shell library portion of libretools"
  52. license=(GPL-2.0-only)
  53. conflicts=('xbs')
  54. optdepends=(
  55. 'libretools: for libreblacklist/blacklist.sh'
  56. 'wget: for libreblacklist/blacklist.sh'
  57. )
  58. cd "$srcdir/$pkgbase-$pkgver"
  59. make install-librelib DESTDIR="$pkgdir"
  60. }
  61. package_gitget() {
  62. pkgdesc="A simple to use downloader for git URLs"
  63. license=(GPL-2.0-only)
  64. depends=("librelib=$pkgver" git)
  65. cd "$srcdir/$pkgbase-$pkgver"
  66. make install-gitget DESTDIR="$pkgdir"
  67. }
  68. package_libretools() {
  69. backup=(etc/libretools.conf
  70. etc/libretools.d/chroot.conf
  71. etc/libretools.d/libredbdiff.conf
  72. etc/libretools.d/librefetch.conf)
  73. conflicts=(devtools)
  74. depends=(
  75. "librelib=$pkgver"
  76. "gitget=$pkgver" # `createworkdir`
  77. "${_pacman_constraints[@]}"
  78. arch-install-scripts # `mkarchroot` uses `pacstrap`
  79. binutils # `libremakepkg`->`makepkg` uses `strip`
  80. expac # `libredbdiff`
  81. fakeroot # `libremakepkg`->`makepkg` uses `fakeroot`
  82. make # `librefetch`
  83. openssh # `librerelease`
  84. #pacutils # `librechroot` uses `pacsift` # TODO: not yet, it doesn't
  85. rsync # `librerelease` and `makechrootpkg.sh`
  86. 'systemd-tools>=234' # `systemd-nspawn` # TODO: merge 'nonsystemd' branch
  87. tokyocabinet # `toru`
  88. #namcap # `libremakepkg` # FIXME: Namcap is currently disabled in libremakepkg :-(
  89. subversion # `diff-unfree`
  90. wget # `aur`, optdepend for librelib:`blacklist`
  91. )
  92. optdepends=(
  93. 'qemu-user-static-binfmt: To build ARM packages from x86'
  94. )
  95. cd "$srcdir/$pkgbase-$pkgver"
  96. make install-libretools DESTDIR="$pkgdir"
  97. }