123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151 |
- # Maintainer (arch): Eli Schwartz <eschwartz@archlinux.org>
- # Maintainer (arch): Jonas Witschel <diabonas@archlinux.org>
- # Contributor: Daniel Landau <daniel.landau@iki.fi>
- # Contributor: Einhard Leichtfuß <alguien@respiranto.de>
- # Contributor: Xyne
- # Contributor: David Manouchehri <d@32t.ca>
- # Contributor: Alexander Fehr <pizzapunk gmail com>
- # Contributor: Thomas Jost <schnouki schnouki net>
- # Contributor: Hinrich Harms <arch hinrich de>
- # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
- # parabola changes and rationale:
- # * replace 'thunderbird' dependency with 'icedove'
- # * apply dependency version constraints
- # * allow building arch-specific packages (different version constraints)
- # * pin to strongly-coupled dependency versions
- _pkgname=thunderbird-extension-enigmail
- pkgname=icedove-extension-enigmail
- pkgver=2.1.7
- pkgrel=3
- pkgrel+=.parabola3
- _icedove_epoch=1
- pkgdesc="OpenPGP message encryption and authentication for Icedove"
- arch=(armv7h i686 x86_64) # this could be an 'any' package; but arches roll at different speeds
- url="https://www.enigmail.net/"
- license=('MPL' 'GPL3')
- depends=('gnupg' 'icedove')
- makedepends=('zip' 'python' 'perl')
- replaces=($_pkgname)
- source=("https://www.enigmail.net/download/source/enigmail-${pkgver}.tar.gz"{,.asc}
- "0001-preferences-disable-pEpAutoDownload-by-default.patch"
- "0001-Disable-Thunderbird-78-upgrade-warning-message.patch"
- "0001-genxpi-make-XPI-files-reproducible.patch")
- sha512sums=('1b57091c8ab9aaa086f327b78d904d688c850b6d39e37e2dac82e0629c0279723eae4608ecd08a24efe9ed1bdc86fbc497e97cd800c7349a70612a42b98f3e41'
- 'SKIP'
- 'baebd963400574db89be747a4419534f945bdc64136d4014656ff98a9615a23984bca724da3f3840670979aab08ce441eee067921e21d0cb216938a20ed785b2'
- '4ddf887765e4296b3c639748d875b179d1e2a5fb38ad16e2918f115a9ff9a05e2f9c66218544f7ab8189f096908df761d4047fd5d23972c02737e46c4a0c843c'
- '3902e09d801f8a3fd493450a85c23d3cd95c68465df0025599e6c923b9708a6cb0cb09920170ec5055d55a56e287ae468460fca150f7be8af9d83cffa1a40427')
- b2sums=('8f6d1ec16b48219c75c6dbcddf4807ed57965eeec29776e7c757d5aa34da6bfdbbb58964ee3d7de2efcb65ab69fa5b020f1a8ec01cd8eee662d8195a217cdc69'
- 'SKIP'
- 'c593ed7b094d9feecb2f14624cf0628ab390c96f0fb0212ab0069333508b59057ef4b0518da1bf59eb8aaf0942303c4c45afab76d0b8e77a93763eab975cb4c0'
- 'a2ba38e56f14a87834023076a75a6c59bc17488104227d8db3e31072f2dcc6488808a980b4073111dec4cf4661349c3e995b8226808c3038d96f2cab666eb90b'
- '55709a3fd099fab4b11289518a44f2b53e81031606529cec5b4786e796de438faefa52f2a7ab3d29d6b3aca120e279f30d6d7ba3c3e3d02ca2abcb85f1652661')
- validpgpkeys=('4F9F89F5505AC1D1A260631CDB1187B9DD5F693B') # Patrick Brunschwig <patrick@enigmail.net>
- _version_constraint() # (dep_pkgname [precision])
- {
- Log() { [[ "${FUNCNAME[2]}" == package ]] && echo "$@" >&2 || : ; }
- local dep_pkgname=$1
- declare -i req_precision=$2
- local full_version=$(pacman -S --print-format='%v' ${dep_pkgname} 2> /dev/null | tail -n 1)
- local n_dots=$(tmp=${full_version%-*} ; tmp=${tmp//[^\.]} ; echo "${#tmp}" ;)
- local def_precision=$(( n_dots + 1 ))
- local is_prec_valid=$(( req_precision > 0 && req_precision <= def_precision ))
- local precision=$((( is_prec_valid )) && echo ${req_precision} || echo ${def_precision})
- local pkgver_rx='[0-9A-Za-z_]+'
- pkgver_rx=$(sed 's|\]|\+]|' <<<${pkgver_rx}) # according to the wiki, '+' is not allowed,
- # but some pkgver have it (eg: 5.15.10+kde+r130)
- local subver_rx='\.'${pkgver_rx}
- local pkgrel_rx='[0-9]+'
- local garbage_rx='[^0-9].*'
- local capture_rx=${pkgver_rx}
- for (( n_dots=1 ; n_dots < precision ; ++n_dots )) ; do capture_rx+=${subver_rx} ; done ;
- local version pkgrel has_dot_char version_min version_max constraint_string
- declare -i subver subver_inc pkgrel_inc
- if [[ "${full_version}" =~ ^(${capture_rx})(${subver_rx})*-(${pkgrel_rx}).*$ ]]
- then version=${BASH_REMATCH[1]} # pkgver cut to the requested precision
- #unused=${BASH_REMATCH[2]} # discarded pkgver segments
- pkgrel=${BASH_REMATCH[3]} # pkgrel with non-numerics right-trimmed
- has_dot_char=$([[ "${version}" =~ \. ]] ; echo $(( ! $? )) ; )
- subver=$(sed "s|${garbage_rx}||" <<<${version##*.}) # right-trim from any non-numeric
- version=$( (( has_dot_char )) && echo ${version%.*}.${subver} || echo ${subver} )
- subver_inc=$(( subver + 1 ))
- pkgrel_inc=$(( pkgrel + 1 ))
- version_min=$( (( ! is_prec_valid )) && echo ${full_version%-*}-${pkgrel} || \
- echo ${version} )
- version_max=$( ( (( ! is_prec_valid )) && echo ${full_version%-*}-${pkgrel_inc} ) || \
- ( [[ "${version}" =~ \. ]] && echo ${version%.*}.${subver_inc} ) || \
- echo ${subver_inc} )
- constraint_string="${dep_pkgname}>=${version_min} ${dep_pkgname}<${version_max}"
- Log "Applied version constraint: '${constraint_string}'"
- else Log "ERROR: in _version_constraint() parsing: dep_pkgname='${dep_pkgname}' full_version='${full_version}'"
- exit 1
- fi
- unset -f Log
- echo -n "${constraint_string}"
- }
- prepare() {
- cd "${srcdir}"/enigmail
- # Using vendor settings via /usr/lib/thunderbird/defaults/preferences/enigmail.js
- # does not seem to work.
- patch -p1 -i ../0001-preferences-disable-pEpAutoDownload-by-default.patch
- # Disable warning message in favour of a versioned dependency to discourage partial upgrades
- patch -p1 -i ../0001-Disable-Thunderbird-78-upgrade-warning-message.patch
- # Make timestamps in the generated XPI file respect SOURCE_DATE_EPOCH
- # (https://gitlab.com/enigmail/enigmail/-/merge_requests/45)
- patch -p1 -i ../0001-genxpi-make-XPI-files-reproducible.patch
- }
- build() {
- cd "${srcdir}"/enigmail
- ./configure
- make -j1 # fails with -j greater than 1
- }
- package() {
- # pin to strongly-coupled dependency versions
- depends=( ${depends[*]/gnupg/} $(_version_constraint 'gnupg' ) )
- depends=( ${depends[*]/icedove/} $(_version_constraint 'icedove') )
- # upstream min thunderbird version contraint
- local min_icedove_ver=$(grep strict_min_version "${srcdir}"/enigmail/build-tb/dist/manifest.json | sed 's|.*: "\([0-9]*\)\..*|\1|g')
- if (( min_icedove_ver + 0 ))
- then local constraint_string="icedove>=${_icedove_epoch}:${min_icedove_ver}"
- depends+=(${constraint_string})
- echo "applied upstream icedove version constraint: ${constraint_string}"
- fi
- cd "${srcdir}"/enigmail
- if ! _extension_id="$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' build-tb/dist/install.rdf 2>/dev/null)" ||
- [[ -z $_extension_id ]]; then
- _extension_id="$(sed -n 's/.*"id": "\(.*\)".*/\1/p' build-tb/dist/manifest.json)"
- fi
- _extension_dest="${pkgdir}/usr/lib/icedove/extensions/${_extension_id}"
- # Should this extension be unpacked or not?
- if grep -q '<em:unpack>true</em:unpack>' build-tb/dist/install.rdf 2>/dev/null; then
- install -dm755 "${_extension_dest}"
- cp -R build-tb/dist/* "${_extension_dest}"
- chmod -R ugo+rX "${_extension_dest}"
- else
- install -Dm644 build-tb/enigmail-${pkgver}.xpi "${_extension_dest}.xpi"
- fi
- }
|