PKGBUILD 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # $Id: PKGBUILD 114621 2014-07-02 09:40:38Z alucryd $
  2. # Maintainer (arch): Maxime Gauduin <alucryd@gmail.com>
  3. # Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
  4. # Contributor: Sander Deryckere <sanderd17@gmail.com>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. # Contributor: Márcio Silva <coadde@hyperbola.info>
  7. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  8. # Contributor: Jorge Araya Navarro <elcorreo@deshackra.com>
  9. pkgname=faience-icon-theme
  10. pkgver=0.5.1
  11. pkgrel=3.parabola2
  12. pkgdesc='An icon theme based on Faenza, without nonfree distros and application icons (Parabola rebranded)'
  13. url='http://tiheum.deviantart.com/art/Faience-icon-theme-255099649'
  14. license=('GPL3')
  15. arch=('any')
  16. replaces=(${pkgname}-libre)
  17. conflicts=(${pkgname}-libre)
  18. depends=('faenza-icon-theme')
  19. source=("http://ppa.launchpad.net/tiheum/equinox/ubuntu/pool/main/f/${pkgname}/${pkgname}_${pkgver}.tar.gz"
  20. 'start-here-parabola-symbolic.svg')
  21. sha256sums=('da4e6e921c465caeb8904d4fc6a183b173c8000c08abce625b5b6739f5a0867a'
  22. 'ad3a47c9545358046b8ef1695cbc6effc913d7affbf27017744419d33e66aea6')
  23. prepare() {
  24. cd ${pkgname}-${pkgver%.*}
  25. rm -rv debian
  26. # remove nonfree distros and application logos
  27. for nonfree in archlinux debian fedora frugalware gentoo linux-mint mandriva opensuse redhat slackware ubuntu flash rpmdrake skype; do
  28. find -name *$nonfree* -delete
  29. done
  30. # add the Parabola GNU/Linux-libre logo to the source code
  31. cp -a "$srcdir/start-here-parabola-symbolic.svg" Faience/places/scalable
  32. # set the Parabola GNU/Linux-libre start menu logo
  33. cd Faience/places/scalable
  34. ln -sf start-here{-parabola-symbolic,-symbolic}.svg
  35. }
  36. package() {
  37. cd ${pkgname}-${pkgver%.*}
  38. install -dm 755 "${pkgdir}"/usr/share/icons
  39. cp -dr --no-preserve=ownership Faience* "${pkgdir}"/usr/share/icons/
  40. # Fix permissions
  41. find "${pkgdir}" -type d -exec chmod 755 {} +
  42. find "${pkgdir}" -type f -exec chmod 644 {} +
  43. }
  44. # vim: ts=2 sw=2 et: