PKGBUILD 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Maintainer: Parabola GNU/Linux-libre Team
  2. # Maintainer (Arch): Arch Linux Team
  3. # Contributor (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
  4. # Contributor (Arch): Eli Schwartz <eschwartz@archlinux.org>
  5. pkgname=base
  6. pkgver=3
  7. pkgrel=2
  8. pkgdesc='Minimal package set to define a basic Arch Linux installation'
  9. url='https://www.archlinux.org'
  10. arch=('any')
  11. license=('GPL')
  12. depends=(
  13. # very very base
  14. 'filesystem' 'gcc-libs' 'glibc' 'bash'
  15. # POSIX tools
  16. 'coreutils' 'file' 'findutils' 'gawk' 'grep' 'procps-ng' 'sed' 'tar'
  17. # standard linux toolset
  18. 'gettext' 'pciutils' 'psmisc' 'shadow' 'util-linux' 'bzip2' 'gzip' 'xz'
  19. # distro defined requirements
  20. 'licenses' 'pacman' 'archlinux-keyring' 'systemd' 'systemd-sysvcompat'
  21. # networking, ping, etc
  22. 'iputils' 'iproute2'
  23. )
  24. optdepends=(
  25. 'linux: bare metal support'
  26. )
  27. # Basic Arch→Parabola changes:
  28. pkgrel+=.parabola1
  29. pkgdesc="${pkgdesc/Arch Linux/'Parabola GNU/Linux-libre'}"
  30. url='https://www.parabola.nu'
  31. depends=(
  32. "${depends[@]/archlinux/parabola}"
  33. )
  34. optdepends=(
  35. "${optdepends[@]/linux/linux-libre}"
  36. 'your-freedom: Conflict with known non-free packages'
  37. )
  38. # Deal with the fact that Parabola imports binaries from Arch{,32,ARM}:
  39. arch=('x86_64' 'i686' 'armv7h')
  40. depends+=('archlinux-keyring') # XXX: Should this really be nescessary on non-x86_64 architectures?
  41. depends_i686=('archlinux32-keyring')
  42. depends_armv7h=('archlinuxarm-keyring')
  43. # vim:set sw=2 sts=-1 et: