PKGBUILD 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # SPDX-License-Identifier: CC0-1.0
  2. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  3. # NOTE: This PKGBUILD does not need to be edited manually.
  4. # The package is normally built automatically by the auto-builder.
  5. # To generate a new package, simply push changes to blacklist.git.
  6. # If ${pkgname}-blacklist.txt is modified, the auto-builder will
  7. # replace $pkgver, $_srcver, and the checksum (updpkgsums),
  8. # build and publish the package, and commit the changes to abslibre.
  9. pkgname=your-gaming-freedom # TODO: change any references on the wiki
  10. pkgver=20240212
  11. pkgrel=1
  12. _srcver=835dfa36db23f81dee00165d47d2ac1a95f9d71e
  13. pkgdesc="This meta-package conflicts with emulators for which no libre games, OS or applications exist (yet)"
  14. pkgdesc+=", and games with dubious free culture licensing" # TODO: why not right? - either this, or many games should be deleted
  15. arch=(any)
  16. url=https://wiki.parabola.nu/Blacklist
  17. license=(custom:CCPL:zero)
  18. # license=('CCPL:zero') # TODO: NYI
  19. makedepends=(librelib)
  20. install=${pkgname}.install
  21. _srcname=${pkgname}-blacklist-${_srcver}.txt
  22. source=(${_srcname}::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_srcver})
  23. sha256sums=('a4dc17bb0a8654c0bc1118831469f52d48cb33021870a37194e3b39ec8b3b9ad')
  24. package()
  25. {
  26. # collect blacklisted package names as pacman conflicts
  27. conflicts=( $( libreblacklist normalize < ${_srcname} | \
  28. cut -d: -f1,2 | sed -n 's/:$//p' | sort -u ) )
  29. install -Dm644 ${_srcname} "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
  30. }