123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109 |
- # Maintainer: David P. <megver83@parabola.nu>
- _target=sh-elf
- pkgname=$_target-gcc
- pkgver=11.2.0
- _islver=0.24
- pkgrel=1
- #_snapshot=8-20210107
- pkgdesc='The GNU Compiler Collection - cross compiler for SuperH (bare-metal) target'
- arch=(x86_64 i686 armv7h)
- url='http://gcc.gnu.org/'
- license=(GPL LGPL FDL)
- depends=($_target-binutils libmpc zlib)
- makedepends=(gmp mpfr $_target-newlib)
- optdepends=("$_target-newlib: Standard C library ($_target target)")
- options=(!emptydirs !strip)
- source=(https://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig}
- #https://gcc.gnu.org/pub/gcc/snapshots/$_snapshot/gcc-$_snapshot.tar.xz
- https://libisl.sourceforge.io/isl-$_islver.tar.bz2)
- sha512sums=('d53a0a966230895c54f01aea38696f818817b505f1e2bfa65e508753fcd01b2aedb4a61434f41f3a2ddbbd9f41384b96153c684ded3f0fa97c82758d9de5c7cf'
- 'SKIP'
- 'aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95')
- validpgpkeys=(33C235A34C46AA3FFB293709A328C3A2C3C45C06 # Jakub Jelinek <jakub@redhat.com>
- 13975A70E63C361C73AE69EF6EEB81F8981C74C7) # Richard Guenther <richard.guenther@gmail.com>
- if [ -n "$_snapshot" ]; then
- _basedir=gcc-$_snapshot
- else
- _basedir=gcc-$pkgver
- fi
- prepare() {
- cd $_basedir
- # link isl for in-tree builds
- ln -sf ../isl-$_islver isl
- echo $pkgver > gcc/BASE-VER
- # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
- sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" "$srcdir"/$_basedir/{libiberty,gcc}/configure
- mkdir $srcdir/gcc-build
- }
- build() {
- cd gcc-build
- # using -pipe causes spurious test-suite failures
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS=${CFLAGS/-pipe/}
- CXXFLAGS=${CXXFLAGS/-pipe/}
- if [ "$CARCH" = i686 ]; then
- # using -Werror=format-security causes i686 build to fail
- CXXFLAGS+=' -Wno-error=format-security'
- fi
- $srcdir/$_basedir/configure \
- --target=$_target \
- --prefix=/usr \
- --libexecdir=/usr/lib \
- --with-sysroot=/usr/$_target \
- --with-native-system-header-dir=/include \
- --enable-languages=c,c++ \
- --enable-plugins \
- --enable-shared \
- --disable-decimal-float \
- --disable-libffi \
- --disable-libgomp \
- --disable-libmudflap \
- --disable-libquadmath \
- --disable-libssp \
- --disable-libstdcxx-pch \
- --disable-nls \
- --disable-threads \
- --disable-tls \
- --with-gnu-as \
- --with-gnu-ld \
- --with-system-zlib \
- --with-newlib \
- --with-python-dir=share/gcc-$_target \
- --with-gmp \
- --with-mpfr \
- --with-mpc \
- --with-isl \
- --with-libelf \
- --enable-gnu-indirect-function
- make
- }
- package() {
- make -C gcc-build DESTDIR="$pkgdir" install-gcc install-target-{libgcc,libstdc++-v3}
- # strip target binaries
- find "$pkgdir"/usr/lib/gcc/$_target/ "$pkgdir"/usr/$_target/lib \
- -type f -and \( -name \*.a -or -name \*.o \) \
- -exec $_target-objcopy -R .comment -R .note -R .debug_info -R .debug_aranges \
- -R .debug_pubnames -R .debug_pubtypes -R .debug_abbrev -R .debug_line \
- -R .debug_str -R .debug_ranges -R .debug_loc '{}' \;
- # strip host binaries
- find "$pkgdir/usr/bin/" "$pkgdir/usr/lib/gcc/$_target/" -type f \
- -and \( -executable \) -exec strip '{}' \;
- # Remove files that conflict with host gcc package
- rm -r "$pkgdir/usr/share/"{man/man7,info}
- }
|