PKGBUILD 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright (C) 2019,2020 Andreas Grapentin <andreas@grapentin.org>
  2. # Copyright (C) 2019,2020,2021,2023 bill-auger <bill-auger@programmer.net>
  3. # This recipe is free software: you can redistribute it and/or modify
  4. # it under the terms of the CC0 1.0 License.
  5. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  6. pkgname=parabola-vmbootstrap
  7. pkgver=20230816
  8. pkgrel=1
  9. arch=(any)
  10. pkgdesc="Scripts to build and boot raw Parabola system images and release tarballs"
  11. license=(GPL3)
  12. url=https://git.parabola.nu/parabola-vmbootstrap.git/
  13. depends=(arch-install-scripts bash binutils librelib parted qemu
  14. qemu-arch-extra qemu-user-static-binfmt sudo wget)
  15. makedepends=(git)
  16. source=(git+https://git.parabola.nu/${pkgname}.git#tag=v${pkgver})
  17. sha256sums=('SKIP')
  18. package()
  19. {
  20. local script
  21. # main scripts
  22. cd "${srcdir}"/${pkgname}/src/
  23. for script in *.sh
  24. do install -Dm755 ./${script} "${pkgdir}"/usr/bin/${script}
  25. done
  26. # helpers
  27. for script in *.sh.inc
  28. do install -Dm644 ./${script} "${pkgdir}"/usr/lib/${pkgname}/${script}
  29. done
  30. # hooks
  31. cd "${srcdir}"/${pkgname}/src/hooks/
  32. for script in hook-*.sh
  33. do install -Dm644 ./${script} "${pkgdir}"/usr/lib/${pkgname}/${script}
  34. done
  35. }