PKGBUILD 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # $Id$
  2. # Maintainer (arch): Tobias Powalowski <tpowa@archlinux.org>
  3. # Maintainer (arch): Thomas Baechler <thomas@archlinux.org>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # parabola changes and rationale (based on extra/linux-manpages):
  6. # changed upstream source to linux-libre
  7. pkgname=linux-libre-manpages
  8. pkgver=4.10_gnu
  9. pkgrel=1
  10. pkgdesc="Kernel hackers manual - Section 9 manpages that comes with the Linux-libre kernel."
  11. arch=('any')
  12. url="https://linux-libre.fsfla.org/"
  13. license=('GPL2')
  14. makedepends=('xmlto' 'docbook-xsl')
  15. replaces=('linux-manpages' 'kernel26-manpages')
  16. conflicts=('linux-manpages' 'kernel26-manpages')
  17. provides=('linux-manpages' 'kernel26-manpages')
  18. options=('!zipman')
  19. source=("https://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver//_/-}/linux-libre-${pkgver//_/-}.tar.xz"{,.sign})
  20. sha256sums=('8a5e5d69a71480d90f9e8db9f8c6fdad71adb1e445b4d80eb81adf1de7fbff98'
  21. 'SKIP')
  22. validpgpkeys=('474402C8C582DAFBE389C427BCB7CF877E7D47A7') # Alexandre Oliva
  23. build() {
  24. cd "${srcdir}/linux-${pkgver%_*}"
  25. make mandocs
  26. }
  27. package() {
  28. cd "${srcdir}/linux-${pkgver%_*}"
  29. # fix install path
  30. sed -i -e "s:/usr/local/man/man9/:${pkgdir}/usr/share/man/man9/:g" Documentation/DocBook/Makefile
  31. make installmandocs
  32. #install -d "${pkgdir}/usr/share/man/man9/"
  33. #install "${srcdir}"/linux-$pkgver/Documentation/DocBook/man/*/*.9.gz "${pkgdir}/usr/share/man/man9/"
  34. # find "${pkgdir}" -type f -exec chmod 644 {} \;
  35. }