PKGBUILD 896 B

12345678910111213141516171819202122232425262728293031
  1. # Maintainer: Parabola Project <dev@lists.parabola.nu>
  2. pkgname=your-initfreedom
  3. pkgdesc="This package conflicts with every package known to work only for/with systemd."
  4. license=('GPL3')
  5. url="https://git.parabola.nu/blacklist.git"
  6. pkgver=20220719
  7. _gitver=daf9eebc77cc719c818165e256efd5e0d5dee7aa
  8. pkgrel=1
  9. arch=('any')
  10. install="${pkgname}.install"
  11. makedepends=(librelib)
  12. source=("blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver}")
  13. sha512sums=('0060ebc516b1aee1149186e53a1c665d6790da2db7e43ade136731c8b5bd7ab24c4ce9431af8c5a06f3ad569ab73bcd2e5ff0179ac3c8f332ae78fdc266addeb')
  14. package() {
  15. cd "$srcdir"
  16. conflicts=($( \
  17. < blacklist-${_gitver}.txt \
  18. libreblacklist normalize | \
  19. cut -d: -f1,2 | \
  20. sed -n 's/:$//p' | \
  21. sort -u \
  22. ))
  23. install -Dm644 blacklist-${_gitver}.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
  24. }