12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273 |
- # Maintainer: Nathan Owens <ndowens@artixlinux.org>
- # Contributor: Jan de Groot <jgc@archlinux.org>
- pkgname=polkit
- pkgver=121
- pkgrel=1
- pkgrel+=.nonsystemd1
- pkgdesc="Application development toolkit for controlling system-wide privileges"
- url="https://gitlab.freedesktop.org/polkit/polkit"
- arch=(x86_64)
- arch+=(i686 armv7h)
- license=(LGPL)
- depends=(glib2 pam expat elogind js78 duktape)
- makedepends=(meson gtk-doc gobject-introspection git)
- checkdepends=(python-dbusmock)
- provides=(libpolkit-{agent,gobject}-1.so)
- backup=(etc/pam.d/polkit-1)
- options=(debug)
- _commit=827b0ddac5b1ef00a47fca4526fcf057bee5f1db # tags/121
- source=("git+https://gitlab.freedesktop.org/polkit/polkit.git#commit=$_commit"
- '99-parabola.rules'
- meson-0.61.diff)
- b2sums=('SKIP'
- 'd320d928b5480b5b8143717e6f88101912709020efc9583fbb233a2cc11aff51d36226b94cf69104db06f330e04d4dcfd6e4c7b027df75a3c72c43adec625fb2'
- '29cef1cf9265ec0b70bf5a46655ee51b9855ce64e47636809b9704ca80edaf5777060d7469eea15a4126791d9290d44901726b6496acf83e41f46a96fe137ead')
- pkgver() {
- cd polkit
- git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
- }
- prepare() {
- cd polkit
- }
- build() {
- local meson_options=(
- -D examples=true
- -D gtk_doc=true
- -D man=true
- -D os_type=redhat
- -D session_tracking=libelogind
- -D tests=true
- -D systemdsystemunitdir=foo
- )
- arch-meson polkit build "${meson_options[@]}"
- meson compile -C build
- }
- check() {
- meson test -C build --print-errorlogs -t 3
- }
- package() {
- meson install -C build --destdir "$pkgdir"
- install -d -o root -g 102 -m 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
- mv "$pkgdir"/{etc,usr/share}/polkit-1/rules.d/50-default.rules
- install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf" <<END
- u polkitd 102 "PolicyKit daemon"
- m polkitd proc
- END
- install -m0644 "${srcdir}"/99-parabola.rules "${pkgdir}"/etc/polkit-1/rules.d
- # workaround the unit enforcement, atm can't be disabled, needs patching
- rm -rf "${pkgdir}"/usr/foo
- }
- # vim:set sw=2 et:
|