PKGBUILD 4.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495
  1. # Maintainer (Arch): David Runge <dvzrv@archlinux.org>
  2. # Contributor (Arch): Alexander Epaneshnikov <aarnaarn2@gmail.com>
  3. # Contributor (Arch): Tom Gundersen <teg@jklm.no>
  4. # Contributor (Arch): Jan de Groot <jgc@archlinux.org>
  5. # Contributor (Arch): Giovanni Scafora <giovanni@archlinux.org>
  6. # Maintainer: David P. <megver83@parabola.nu>
  7. pkgname=brltty
  8. pkgver=6.3
  9. pkgrel=1
  10. pkgrel+=.nonsystemd1
  11. pkgdesc="Braille display driver for Linux/Unix"
  12. arch=('x86_64')
  13. arch+=('i686' 'armv7h')
  14. url="https://brltty.app"
  15. license=('LGPL2.1')
  16. depends=('bluez-libs' 'gcc-libs' 'glibc' 'liblouis' 'libspeechd' 'pcre'
  17. 'polkit' 'tcl')
  18. makedepends=('alsa-lib' 'at-spi2-atk' 'at-spi2-core' 'atk' 'cython' 'dbus'
  19. 'dracut' 'expat' 'festival' 'glib2' 'gpm' 'icu' 'java-environment'
  20. 'libxaw' 'ncurses' 'ocaml-ctypes' 'ocaml-findlib' 'speech-dispatcher'
  21. 'elogind')
  22. makedepends_x86_64=('espeak-ng')
  23. makedepends_i686=('espeak')
  24. makedepends_armv7h=('espeak-ng')
  25. optdepends=('at-spi2-core: X11/GNOME Apps accessibility'
  26. 'atk: ATK bridge for X11/GNOME accessibility'
  27. 'espeak-ng: espeak-ng driver'
  28. 'java-runtime: Java support'
  29. 'libxaw: X11 support'
  30. 'libxt: X11 support'
  31. 'libx11: for xbrlapi'
  32. 'libxfixes: for xbrlapi'
  33. 'libxtst: for xbrlapi'
  34. 'ocaml: OCaml support'
  35. 'python: Python support'
  36. 'speech-dispatcher: speech-dispatcher driver')
  37. provides=('libbrlapi.so')
  38. backup=(etc/brltty.conf)
  39. options=('!emptydirs')
  40. install=brltty.install
  41. source=("https://brltty.app/archive/${pkgname}-${pkgver}.tar.bz2"
  42. "${pkgname}.tmpfiles"
  43. "${pkgname}.sysusers"
  44. "0001-libbrlapi-use-elogind-instead-of-systemd.patch")
  45. sha512sums=('687fbb30703d4c9fd7b55d27fabecf26c58f7c032c82bcdee1405259da74f85516e268fc49d1bdb2f704b92532cf5c466712cc09b1a4ba5304d4e021af74b7b8'
  46. 'a530fe66983768f9dc544af01c586abc101dfa2ed76885b4f1fd78c483b59e8445f2c0dbbfb865dd1cf2874342c346bd35ce978ab246e9cdd31d2d489a14e770'
  47. 'cc2e2d5f33d4e11d6ff828aefc0773ccdc02127ce2f00649c1e3f8d4b39b90789f4a0e41385b344f850c38bd4a1df36d3d9d413a59144d431defdd343633f800'
  48. '88e1ed1d45e0ec8f10ca3f0fcb778fa1465d6799ee5d570c9f4ef22cb29dee8e7854feaa7c6b99dff2dfea15072fad4c7361c2d9fdff1f7abc6ccea40e6fd03c')
  49. b2sums=('c321e1bdd6d7956620fa354edcf8eee0c8a0011ebfabb4cff98cb5a22c23d5667e6b73cbdbf282c9c36cc4d50ded4e147174c45da36e3fec03cc0a8d2121459a'
  50. '59f50e367d2e6c6704902ebbd254232aa17c741c9a43ba27d0ebaa5fd4a86f62bc8bdd08e8e4562437dea0efa9d49845e40c022b8c4d7110675d81bf63ac4df4'
  51. 'e6b7453360ef92254ff1049b387c9ee45f3be0e0259c9c3670154938f61ec4142b2de330401d09e1290ed9ffe8e390ede3472dab0e2f4c69b497f9ac19795aad'
  52. 'b29df2269b4c3d0afd64fcf2d38d0ca4a2a53f36cea62900765f782c76f2cae6b36bfca693194cc26e6d53a9f9af997d2bb5180062a7e3b0501d6c38e83936d0')
  53. prepare() {
  54. cd "${pkgname}-${pkgver}"
  55. patch -Np1 -i ../0001-libbrlapi-use-elogind-instead-of-systemd.patch
  56. ./autogen
  57. }
  58. build() {
  59. cd "${pkgname}-${pkgver}"
  60. ./configure --prefix=/usr \
  61. --sysconfdir=/etc \
  62. --localstatedir=/var \
  63. --mandir=/usr/share/man \
  64. --with-scripts-directory=/usr/lib/brltty \
  65. --with-tables-directory=/usr/share/brltty \
  66. --with-writable-directory=/run/brltty \
  67. --enable-gpm \
  68. --disable-stripping
  69. make
  70. }
  71. package() {
  72. depends+=('libasound.so' 'libdbus-1.so' 'libexpat.so' 'libgio-2.0.so'
  73. 'libglib-2.0.so' 'libgobject-2.0.so' 'libicuuc.so' 'libgpm.so'
  74. 'libncursesw.so' 'libelogind.so')
  75. cd "${pkgname}-${pkgver}"
  76. make INSTALL_ROOT="${pkgdir}" install-udev
  77. # dracut support may still be problematic
  78. # https://bugs.archlinux.org/task/69424
  79. # https://bugs.archlinux.org/task/69440
  80. make INSTALL_ROOT="${pkgdir}" install-dracut
  81. make INSTALL_ROOT="${pkgdir}" install-polkit
  82. install -vDm 644 "Documents/${pkgname}.conf" -t "${pkgdir}/etc/"
  83. install -vDm 644 "../${pkgname}.sysusers" \
  84. "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
  85. install -vDm 644 "../${pkgname}.tmpfiles" \
  86. "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
  87. # fix directory permission and ownership
  88. install -vdm 750 -o root -g 102 "$pkgdir/usr/share/polkit-1/rules.d"
  89. }