PKGBUILD 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Maintainer (arch): Bruno Pagani <archange@archlinux.org>
  2. # Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
  3. # parabola changes and rationale:
  4. # - no changes
  5. # - temporary 'jami-qt' build without qt6-webengine
  6. # the next jami release should have this VCS change;
  7. # so the arch pckage will be FDSG-fit then
  8. # - NOTE: this is built from VCS; but so was the
  9. # latest arch package - AFAIK, this should be
  10. # named 'jami-qt-git' - it is a one-time
  11. # blacklist replacement though; so it is less
  12. # troublesome to keep the arch pkgname
  13. # - NOTE: jami-{daemon,libclient,qt} versions are all tightly coupled,
  14. # even at the VCS level
  15. # implied build order: jami-daemon <- jami-libclient <- jami-qt
  16. pkgname=jami-libclient
  17. pkgver=20220505
  18. pkgrel=1
  19. pkgrel+=.parabola1
  20. pkgdesc="Free and universal communication platform which preserves the users’ privacy and freedoms (client communication library)"
  21. arch=(x86_64)
  22. url="https://jami.net"
  23. license=(GPL3)
  24. groups=(jami)
  25. depends=(jami-daemon qt6-base)
  26. makedepends=(git cmake qt6-tools)
  27. provides=(libjamiclient)
  28. conflicts=(libjamiclient)
  29. replaces=(libjamiclient)
  30. _commit=c5bca2933fb02ef7f81e8fe0772801a4f97fd1f5
  31. source=(git+https://git.jami.net/savoirfairelinux/jami-libclient.git#commit=${_commit})
  32. md5sums=(SKIP)
  33. # pkgver() {
  34. # cd ${pkgname}
  35. # TZ=UTC git show -s --pretty=%cd --date=format-local:%Y%m%d HEAD
  36. # }
  37. build() {
  38. cmake -B build -S jami-libclient \
  39. -DCMAKE_INSTALL_PREFIX=/usr \
  40. -DCMAKE_BUILD_TYPE=Release
  41. make -C build
  42. }
  43. package() {
  44. make -C build DESTDIR="${pkgdir}" install
  45. }