PKGBUILD 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. # Maintainer (Arch): Jan de Groot <jgc@archlinux.org>
  2. # Contributor (Arch): Giovanni Scafora <giovanni@archlinux.org>
  3. # Contributor (Arch): Maël Lavault <moimael@neuf.fr>
  4. # Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
  5. # Maintainer: Andreas Grapentin <andreas@grapentin.org>
  6. # Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
  7. # parabola changes and rationale:
  8. # - Patched to replace nonfree fonts with free fonts.
  9. # - Built without the 'google' plugin
  10. pkgname=abiword
  11. pkgver=3.0.5
  12. pkgrel=1
  13. pkgrel+=.parabola1
  14. pkgdesc='Fully-featured word processor'
  15. pkgdesc+=', without Google search engine and nonfree fonts support'
  16. arch=('x86_64')
  17. arch+=('i686' 'armv7h')
  18. license=('GPL')
  19. url='https://www.abisource.com'
  20. depends=('fribidi' 'wv' 'goffice' 'librsvg' 'enchant' 'desktop-file-utils'
  21. 'redland' 'libical' 'gtk-update-icon-cache' 'loudmouth' 'libwpg' 'libwps' 'libwmf' 'link-grammar'
  22. 'gtkmathview' 'aiksaurus' 'libxslt' 'libsoup' 'libots' 'libgsf' 'psiconv')
  23. makedepends=('pkgconfig' 'boost' 'gobject-introspection' 'libwpd' 'libwps' 'python-gobject' 'autoconf-archive')
  24. conflicts=('abiword-plugins' 'abiword-libre')
  25. replaces=('abiword-plugins' 'abiword-libre')
  26. options=(!makeflags)
  27. source=(https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz{,.asc}
  28. abiword-3.0.0-librevenge.patch
  29. abiword-3.0.1-libwps-0.4.patch
  30. abiword-gcc11.patch::https://github.com/AbiWord/abiword/commit/ef29fc94.patch
  31. aiksaurus-plugin.m4
  32. command-plugin.m4
  33. python-override.patch
  34. enchant-2.1.patch
  35. # https://github.com/AbiWord/abiword/commit/de5dc5fd94a5fe321791d44e88d209a4972264ba
  36. boost-asio.patch)
  37. sha256sums=('1257247e9970508d6d1456d3e330cd1909c4b42b25e0f0a1bc32526d6f3a21b4'
  38. 'SKIP'
  39. '77b52a3722096cec3bfbe4fff3802f51b6c9e0ff7aaa30028c29825fd4e6a65f'
  40. 'f1375b2ab7af2959717cba0259ba546c8e75ef849e84263bdc253019e849cb2a'
  41. 'd0d9baa60349fa3e1e9f594f896b82285a9378141ff973f4265295ab8475c413'
  42. '5f80a2f94f9929cdba9809c5e1a87cd5d537a2518bb879bfb9eab51a71c8dac1'
  43. '2f26826e9d59d80dacd0dae4aceb815804eaa75954e47507a0897794f33e45be'
  44. 'dba1e3265cd42589f17b41fea1a39c8aa4b83c7203b9d5944b578d0ff9c858be'
  45. '444dc2aadea3c80310a509b690097541573f6d2652c573d04da66a0f385fcfb2'
  46. '3d119595c8080f90570ce09e02d6765a0cb84b16f4cc51ef8eee4ff289c19e77')
  47. validpgpkeys=('6C44DB3E0BF3EAF5B433239A5FEE05E6A56E15A3') # Hubert Figuiere <hub@figuiere.net>
  48. source+=('liberation-fonts.patch')
  49. sha256sums+=('8a0b6e444e937924743f95c747cbe395a30fb8677a010e60c973b9039e258079')
  50. prepare() {
  51. cd $pkgname-$pkgver
  52. # fix build with librevenge based import filters
  53. patch -Np0 -i ../abiword-3.0.0-librevenge.patch
  54. # Fix libwpd 0.4 detection
  55. patch -Np1 -i ../abiword-3.0.1-libwps-0.4.patch
  56. # Fix build with GCC 11
  57. patch -p1 -i ../abiword-gcc11.patch
  58. # Fix python override code to work with Python 3.x
  59. patch -Np1 -i ../python-override.patch
  60. # Replace deprecated enchant functions
  61. patch -Np1 -i ../enchant-2.1.patch
  62. # Replace nonfree fonts support to liberation fonts
  63. patch -Np1 -i ../liberation-fonts.patch
  64. # Install missing m4 file
  65. install -m644 ../aiksaurus-plugin.m4 plugins/aiksaurus/plugin.m4
  66. install -m644 ../command-plugin.m4 plugins/command/plugin.m4
  67. # Generate m4 file for configure
  68. find plugins -name plugin.m4 | xargs cat > plugin-configure.m4
  69. # enchant-2 naming change
  70. sed -i 's/enchant >=/enchant-2 >=/' configure.ac
  71. libtoolize --force
  72. autoreconf -fi
  73. }
  74. build() {
  75. cd $pkgname-$pkgver
  76. # `--enable-plugins` has the complete list of plugins
  77. # Disabled plugins:
  78. # - google: Search Google for your selected text
  79. ./configure --prefix=/usr \
  80. --enable-shared \
  81. --disable-static \
  82. --enable-clipart \
  83. --enable-templates \
  84. --enable-plugins="aiksaurus applix babelfish bmp clarisworks collab \
  85. command docbook eml epub freetranslation garble gdict \
  86. gimp goffice grammar hancom hrtext iscii kword latex \
  87. loadbindings mathview mht mif mswrite opendocument \
  88. openwriter openxml ots paint passepartout pdb pdf \
  89. presentation psion s5 sdw t602 urldict wikipedia wmf \
  90. wml wordperfect wpg xslfo" \
  91. --enable-introspection
  92. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  93. make
  94. }
  95. package() {
  96. cd $pkgname-$pkgver
  97. make DESTDIR="$pkgdir" install
  98. }