PKGBUILD 967 B

123456789101112131415161718192021222324252627
  1. # Copyright (C) 2019 Freemor <freemor@freemor.ca>
  2. # This program is free software: you can redistribute it and/or modify
  3. # it under the terms of the CC0 1.0 License.
  4. # Maintainers: Parabola hackers <dev@lists.parabola.nu>
  5. pkgname=your-system-sanity
  6. pkgdesc="This package Warns about and fails to install/upgrade any offending Third Party Package Manager."
  7. license=('GPL3')
  8. url="https://git.parabola.nu/abslibre.git"
  9. pkgver=0.2
  10. pkgrel=2
  11. arch=('any')
  12. depends=('pacman')
  13. groups=('base' 'base-openrc')
  14. source=('TPPM.hook' 'TPPMwarn')
  15. sha512sums=('452022078de19bc9353ee3f0a2bfca2142c56b99d21276ae4de00568dbf77e3701bd4edd6e70f7454b35602712d601ce08542afcce7a86370399318d09aa74ba'
  16. 'cc30673b8bdf63c8de6cb0cdd4397f93f3c855a051ce194cb3d2459f83728d8749b661dfab33ae961b64ba6ec4809946421806c596e459101f1da28d2fec6876')
  17. package() {
  18. cd "$srcdir"
  19. install -Dm755 TPPMwarn "$pkgdir"/usr/bin/TPPMwarn
  20. install -Dm644 TPPM.hook "$pkgdir"/etc/pacman.d/hooks/TPPM.hook
  21. }