PKGBUILD 907 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Maintainer:
  2. pkgname=findutils
  3. pkgver=4.6.0
  4. pkgrel=2
  5. pkgdesc="GNU utilities to locate files"
  6. arch=(x86_64 ppc64le)
  7. license=('GPL3')
  8. groups=('base' 'base-devel')
  9. depends=('glibc' 'sh')
  10. url='https://www.gnu.org/software/findutils/'
  11. source=("https://ftp.gnu.org/pub/gnu/findutils/${pkgname}-${pkgver}.tar.gz")
  12. sha1sums=('f18e8aaee3f3d4173a1f598001003be8706d28b0')
  13. #validpgpkeys=('A15B725964A95EE5') # James Youngman <james@youngman.org>
  14. build() {
  15. cd "${srcdir}/${pkgname}-${pkgver}"
  16. # Don't build or install locate because we use mlocate,
  17. # which is a secure version of locate.
  18. sed -i '/^SUBDIRS/s/locate//' Makefile.in
  19. ./configure --prefix=/usr
  20. # don't build locate, but the docs want a file in there.
  21. make -C locate dblocation.texi
  22. make
  23. }
  24. check() {
  25. cd "${srcdir}/${pkgname}-${pkgver}"
  26. make check
  27. }
  28. package() {
  29. cd "${srcdir}/${pkgname}-${pkgver}"
  30. make DESTDIR=$pkgdir install
  31. }