PKGBUILD 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Maintainer: Sébastien "Seblu" Luttringer
  2. # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
  3. # Contributor: Allan McRae <allan@archlinux.org>
  4. # Contributor: judd <jvinet@zeroflux.org>
  5. pkgname=coreutils
  6. pkgver=8.30
  7. pkgrel=1
  8. pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system'
  9. arch=(x86_64 ppc64le)
  10. license=('GPL3')
  11. url='https://www.gnu.org/software/coreutils/'
  12. groups=('base')
  13. depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
  14. source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
  15. validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
  16. md5sums=('ab06d68949758971fe744db66b572816'
  17. 'SKIP')
  18. prepare() {
  19. cd $pkgname-$pkgver
  20. # apply patch from the source array (should be a pacman feature)
  21. local filename
  22. for filename in "${source[@]}"; do
  23. if [[ "$filename" =~ \.patch$ ]]; then
  24. msg2 "Applying patch ${filename##*/}"
  25. patch -p1 -N -i "$srcdir/${filename##*/}"
  26. fi
  27. done
  28. :
  29. }
  30. build() {
  31. cd $pkgname-$pkgver
  32. ./configure \
  33. --prefix=/usr \
  34. --libexecdir=/usr/lib \
  35. --with-openssl \
  36. --enable-no-install-program=groups,hostname,kill,uptime
  37. make
  38. }
  39. check() {
  40. cd $pkgname-$pkgver
  41. #make check
  42. }
  43. package() {
  44. cd $pkgname-$pkgver
  45. make DESTDIR="$pkgdir" install
  46. }
  47. # vim:set ts=2 sw=2 et: