PKGBUILD 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright (C) 2018, 2019 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  2. # This program is free software: you can redistribute it and/or modify
  3. # it under the terms of the CC0 1.0 License.
  4. # Maintainers: Parabola hackers <dev@lists.parabola.nu>
  5. _pkgname=barebox
  6. pkgname=barebox-am335x
  7. pkgver=2019.02.0
  8. pkgrel=1
  9. pkgdesc="Barebox for devices with an am335x system on a chip"
  10. arch=('armv7h')
  11. makedepends=('lzop')
  12. url="http://barebox.org/"
  13. license=('GPL2')
  14. install=${_pkgname}.install
  15. source=("http://barebox.org/download/${_pkgname}-${pkgver}.tar.bz2")
  16. sha512sums=('648827efeec7b2591eaf43daf98368be1902e3f8157c8acd88b9f103078e9989bb158d81eda013e360d6dfdfbb3c7aae0e334fce957663b72ca46f419c33e981')
  17. build() {
  18. cd ${_pkgname}-${pkgver}
  19. unset CFLAGS CXXFLAGS LDFLAGS
  20. if [ "$CARCH" = "armv7h" ]; then
  21. export ARCH=arm
  22. make am335x_mlo_defconfig
  23. make
  24. make omap_defconfig
  25. make
  26. # TODO: Add support for more ARM SOCs and
  27. # CPU architectures (Barebox also supports
  28. # x86 and PowerPC)
  29. fi
  30. }
  31. package() {
  32. cd ${_pkgname}-${pkgver}
  33. mkdir -p "${pkgdir}/boot/barebox/images/"
  34. install -t "${pkgdir}/boot/barebox/images/" images/barebox-*.img
  35. }