PKGBUILD 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Maintainer: Márcio Silva <coadde@hyperbola.info>
  2. # Contributor: André Silva <emulatorman@hyperbola.info>
  3. pkgname=lib32-libclc
  4. pkgver=0.2.0+334+520743b
  5. pkgrel=1.1
  6. pkgdesc="Library requirements of the OpenCL C programming language (32-bit)"
  7. arch=('x86_64')
  8. url="http://libclc.llvm.org/"
  9. license=('MIT')
  10. depends=('libclc')
  11. makedepends=('lib32-clang' 'lib32-llvm' 'python2' 'git' 'gcc-multilib')
  12. options=('staticlibs')
  13. replaces=(lib32-libclc-svn)
  14. provides=(lib32-libclc-svn)
  15. conflicts=(lib32-libclc-svn)
  16. source=('git+http://llvm.org/git/libclc#commit=520743b')
  17. md5sums=(SKIP)
  18. pkgver() {
  19. cd libclc
  20. echo 0.2.0+$(git rev-list --count HEAD)+$(git describe --always)
  21. #git describe --long | sed 's/-/+/g'
  22. }
  23. build() {
  24. cd libclc
  25. sed -i 's/"python < $in >/sys.executable + " < $in >/g' configure.py
  26. python2 ./configure.py --prefix=/usr \
  27. --libexecdir=/usr/lib32/clc \
  28. --pkgconfigdir=/usr/lib32/pkgconfig \
  29. --with-llvm-config=/usr/bin/llvm-config32 \
  30. --with-cxx-compiler="/usr/bin/g++ -m32"
  31. make
  32. }
  33. package() {
  34. cd libclc
  35. make install DESTDIR="$pkgdir"
  36. install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
  37. msg 'remove useless include dir'
  38. rm -vrf $pkgdir/usr/include
  39. }