rules 492 B

1234567891011121314151617181920212223242526272829
  1. #!/usr/bin/make -f
  2. export RUSTUP = 0
  3. # When building packages locally, `env VENDORED=0 CLEAN=0 debuild`
  4. # will build a package using non-vendored dependencies, and
  5. # re-using build artifacts from the last build. Use this in
  6. # local testing.
  7. export VENDORED ?= 1
  8. CLEAN ?= 1
  9. %:
  10. dh $@
  11. override_dh_auto_clean:
  12. ifeq ($(CLEAN),1)
  13. make clean
  14. endif
  15. make version
  16. ifeq ($(VENDORED),1)
  17. if ! ischroot; then \
  18. make vendor; \
  19. fi
  20. endif
  21. override_dh_auto_install:
  22. dh_auto_install -- prefix=/usr