PKGBUILD 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Maintainer (Arch): Ronald van Haren <ronald.archlinux.org>
  2. # Contributor (Arch): judd <jvinet@zeroflux.org>
  3. # Maintainer: André Silva <emulatorman@hyperbola.info>
  4. pkgname=net-tools
  5. pkgver=1.60+git20181103.0eebece
  6. _debver=1.60+git20181103.0eebece
  7. _debrel=1
  8. pkgrel=1
  9. pkgdesc="Configuration tools for GNU/Linux networking"
  10. arch=('i686' 'x86_64')
  11. license=('GPL-2')
  12. url="https://sourceforge.net/projects/net-tools/"
  13. depends=('glibc')
  14. makedepends=('quilt')
  15. replaces=('inetutils')
  16. conflicts=('inetutils')
  17. provides=('inetutils')
  18. source=("https://deb.debian.org/debian/pool/main/n/net-tools/net-tools_$pkgver.orig.tar.xz"
  19. "https://deb.debian.org/debian/pool/main/n/net-tools/net-tools_$_debver-$_debrel.debian.tar.xz"
  20. 'make-net-tools-fhs-compliant.patch')
  21. options=(!makeflags)
  22. sha512sums=('2ae46a478eecbdc42b5233505329fd296137e1f7d603304f55afcc8ed1f0c89877305f2f47ff0794126e5dab063a380992fb4a57ee12f4803f26ef30ae164345'
  23. 'dbec7e5a3220c7c9656c03815ef0f772d082e358d8330644c70b9a50ba4634b77c76f9533e171af1d7a21643166e83c97b9762056cead839a8edd215c2c42c1c'
  24. '9ce8aeda32a8c7be60d96ce32e989f863dfb984aaee2327cde0bbe514e2cd0f2271b459923b5d1baac92d805637b6516776a02a5f035326ea76a0d0e21fe8a07')
  25. prepare() {
  26. cd ${srcdir}/${pkgname}-${pkgver}
  27. # make net-tools FHS compliant
  28. patch -p1 -i ../make-net-tools-fhs-compliant.patch
  29. if [[ ${pkgver%.*} = ${_debver%.*.*} ]]; then
  30. # Debian patches
  31. export QUILT_PATCHES=debian/patches
  32. export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
  33. export QUILT_DIFF_ARGS='--no-timestamps'
  34. mv "$srcdir"/debian .
  35. quilt push -av
  36. fi
  37. }
  38. build() {
  39. cd ${srcdir}/${pkgname}-${pkgver}
  40. yes "" | make
  41. }
  42. package() {
  43. cd ${srcdir}/${pkgname}-${pkgver}
  44. make DESTDIR=${pkgdir} update
  45. # the following is provided by yp-tools
  46. rm "${pkgdir}"/bin/{nis,yp}domainname
  47. rm "${pkgdir}"/usr/share/man/man1/{nis,yp}domainname.1
  48. # install license
  49. install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING
  50. }