123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354 |
- # Maintainer (Arch): Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
- # Maintainer (Arch): Dan McGee <dan@archlinux.org>
- # Maintainer: André Silva <emulatorman@hyperbola.info>
- # Contributor: Márcio Silva <coadde@hyperbola.info>
- # Contributor: Tobias Dausend <throgh@hyperbola.info>
- pkgname=libarchive
- pkgver=3.4.3
- _debver=$pkgver
- _debrel=2
- pkgrel=3
- pkgdesc="Multi-format archive and compression library"
- arch=('i686' 'x86_64')
- url='https://libarchive.org/'
- license=('Simplified-BSD')
- depends=('acl' 'bzip2' 'lz4' 'expat' 'libressl')
- makedepends=('quilt')
- source=("https://libarchive.org/downloads/${pkgname}-${pkgver}.tar.gz"
- "https://deb.debian.org/debian/pool/main/liba/libarchive/libarchive_${_debver}-${_debrel}+deb11u1.debian.tar.xz")
- sha512sums=('d00167dec6e65a0b17b46a1e3bb0242d85716dbc637afd233360cb515b2750dafe0ff0644b9e01ad23534340b405a8551f496c5e39fba9ee99355a515580d65d'
- 'f0237edc02ab5f8f8969bc43f9f9279e248c04e5c22aa3c0be1f1e6b2da8856881c202ba14dcc5a8673b9209714d2457630bb51eca0df160fa2cff4d19d32225')
- prepare() {
- cd $pkgname-$pkgver
- if [[ ${pkgver%.*} = ${_debver%.*} ]]; then
- # Debian patches
- export QUILT_PATCHES=debian/patches
- export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
- export QUILT_DIFF_ARGS='--no-timestamps'
- mv "$srcdir"/debian .
- quilt push -av
- fi
- autoreconf -fi
- }
- build() {
- cd $pkgname-$pkgver
- ./configure \
- --prefix=/usr \
- --without-xml2 \
- --without-nettle \
- --without-zstd \
- --disable-static
- make
- }
- package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/libarchive/COPYING"
- }
|