PKGBUILD 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Maintainer (Arch): Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
  2. # Maintainer (Arch): Dan McGee <dan@archlinux.org>
  3. # Maintainer: André Silva <emulatorman@hyperbola.info>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. # Contributor: Tobias Dausend <throgh@hyperbola.info>
  6. pkgname=libarchive
  7. pkgver=3.4.3
  8. _debver=$pkgver
  9. _debrel=2
  10. pkgrel=3
  11. pkgdesc="Multi-format archive and compression library"
  12. arch=('i686' 'x86_64')
  13. url='https://libarchive.org/'
  14. license=('Simplified-BSD')
  15. depends=('acl' 'bzip2' 'lz4' 'expat' 'libressl')
  16. makedepends=('quilt')
  17. source=("https://libarchive.org/downloads/${pkgname}-${pkgver}.tar.gz"
  18. "https://deb.debian.org/debian/pool/main/liba/libarchive/libarchive_${_debver}-${_debrel}+deb11u1.debian.tar.xz")
  19. sha512sums=('d00167dec6e65a0b17b46a1e3bb0242d85716dbc637afd233360cb515b2750dafe0ff0644b9e01ad23534340b405a8551f496c5e39fba9ee99355a515580d65d'
  20. 'f0237edc02ab5f8f8969bc43f9f9279e248c04e5c22aa3c0be1f1e6b2da8856881c202ba14dcc5a8673b9209714d2457630bb51eca0df160fa2cff4d19d32225')
  21. prepare() {
  22. cd $pkgname-$pkgver
  23. if [[ ${pkgver%.*} = ${_debver%.*} ]]; then
  24. # Debian patches
  25. export QUILT_PATCHES=debian/patches
  26. export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
  27. export QUILT_DIFF_ARGS='--no-timestamps'
  28. mv "$srcdir"/debian .
  29. quilt push -av
  30. fi
  31. autoreconf -fi
  32. }
  33. build() {
  34. cd $pkgname-$pkgver
  35. ./configure \
  36. --prefix=/usr \
  37. --without-xml2 \
  38. --without-nettle \
  39. --without-zstd \
  40. --disable-static
  41. make
  42. }
  43. package() {
  44. cd $pkgname-$pkgver
  45. make DESTDIR="$pkgdir" install
  46. install -Dm644 COPYING "$pkgdir/usr/share/licenses/libarchive/COPYING"
  47. }