stenography.scm 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
  3. ;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
  4. ;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages stenography)
  21. #:use-module (guix build-system python)
  22. #:use-module (guix git-download)
  23. #:use-module ((guix licenses) #:prefix license:)
  24. #:use-module (guix packages)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages qt)
  27. #:use-module (gnu packages check)
  28. #:use-module (gnu packages libusb)
  29. #:use-module (gnu packages python)
  30. #:use-module (gnu packages python-xyz)
  31. #:use-module (gnu packages wxwidgets))
  32. (define-public plover
  33. (package
  34. (name "plover")
  35. (version "4.0.0.dev10")
  36. (source
  37. (origin
  38. (method git-fetch)
  39. (uri (git-reference
  40. (url "https://github.com/openstenoproject/plover")
  41. (commit (string-append "v" version))))
  42. (file-name (git-file-name name version))
  43. (sha256
  44. (base32 "1nyllqv4jq4idgn4cp5mypransw3rh3x8c1h9p6ld1anfr3zx7m0"))))
  45. (build-system python-build-system)
  46. (native-inputs
  47. (list python-pytest))
  48. (inputs
  49. (list python-appdirs
  50. python-pyqt
  51. python-babel
  52. python-dbus
  53. python-hidapi
  54. python-pyserial
  55. python-xlib))
  56. (home-page "https://www.openstenoproject.org/plover/")
  57. (synopsis "Stenography engine")
  58. (description
  59. "Plover (rhymes with @emph{lover}) is a desktop application that
  60. allows anyone to use stenography to write on their computer, up to
  61. speeds of 200WPM and beyond.")
  62. (license license:gpl2+)))