123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566 |
- (define-module (gnu packages stenography)
- #:use-module (guix build-system python)
- #:use-module (guix git-download)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (gnu packages)
- #:use-module (gnu packages qt)
- #:use-module (gnu packages check)
- #:use-module (gnu packages libusb)
- #:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz)
- #:use-module (gnu packages wxwidgets))
- (define-public plover
- (package
- (name "plover")
- (version "4.0.0.dev10")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/openstenoproject/plover")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1nyllqv4jq4idgn4cp5mypransw3rh3x8c1h9p6ld1anfr3zx7m0"))))
- (build-system python-build-system)
- (native-inputs
- (list python-pytest))
- (inputs
- (list python-appdirs
- python-pyqt
- python-babel
- python-dbus
- python-hidapi
- python-pyserial
- python-xlib))
- (home-page "https://www.openstenoproject.org/plover/")
- (synopsis "Stenography engine")
- (description
- "Plover (rhymes with @emph{lover}) is a desktop application that
- allows anyone to use stenography to write on their computer, up to
- speeds of 200WPM and beyond.")
- (license license:gpl2+)))
|