spreadsheet.scm 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
  3. ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
  4. ;;; Copyright © 2021 Jorge Gomez <jgart@dismail.de>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages spreadsheet)
  21. #:use-module (guix packages)
  22. #:use-module (guix git-download)
  23. #:use-module (guix download)
  24. #:use-module (guix utils)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (guix build-system python)
  27. #:use-module (guix licenses)
  28. #:use-module (gnu packages base)
  29. #:use-module (gnu packages bison)
  30. #:use-module (gnu packages check)
  31. #:use-module (gnu packages compression)
  32. #:use-module (gnu packages maths)
  33. #:use-module (gnu packages ncurses)
  34. #:use-module (gnu packages time)
  35. #:use-module (gnu packages pkg-config)
  36. #:use-module (gnu packages python-web)
  37. #:use-module (gnu packages python-xyz)
  38. #:use-module (gnu packages statistics)
  39. #:use-module (gnu packages xml))
  40. (define-public sc-im
  41. (package
  42. (name "sc-im")
  43. (version "0.8.2")
  44. (home-page "https://github.com/andmarti1424/sc-im")
  45. (source (origin
  46. (method git-fetch)
  47. (uri
  48. (git-reference
  49. (url home-page)
  50. (commit (string-append "v" version))))
  51. (file-name (git-file-name name version))
  52. (sha256
  53. (base32
  54. "1nrjnw8sg75i0hkcbvjv7gydjddxjm27d5m1qczpg29fk9991q8z"))))
  55. (build-system gnu-build-system)
  56. (arguments
  57. ;; There are no tests at the moment.
  58. ;; https://github.com/andmarti1424/sc-im/issues/537
  59. ;; https://github.com/andmarti1424/sc-im/pull/385
  60. `(#:tests? #f
  61. #:make-flags (list "-C" "src"
  62. (string-append "CC=" ,(cc-for-target))
  63. (string-append "prefix=" %output))
  64. #:phases
  65. (modify-phases
  66. %standard-phases
  67. (delete 'configure))))
  68. (inputs
  69. (list gnuplot
  70. libxls
  71. libxlsxwriter
  72. libxml2
  73. libzip
  74. ncurses))
  75. (native-inputs
  76. (list pkg-config which bison))
  77. (synopsis "Spreadsheet program with vim-like keybindings")
  78. (description
  79. "@code{sc-im} is a highly configurable spreadsheet program
  80. providing a vim-like experience. @code{sc-im} supports @{gnuplot} interaction,
  81. functions for sorting and filtering, 256 color support, and much more.")
  82. (license bsd-4)))
  83. (define-public visidata
  84. (package
  85. (name "visidata")
  86. (version "2.8")
  87. (source
  88. (origin
  89. (method url-fetch)
  90. (uri (pypi-uri "visidata" version))
  91. (sha256
  92. (base32
  93. "1jfhrk0xvzzqfzs0khbig2dc94718qki8zys1f1a9553vjncvmi6"))))
  94. (build-system python-build-system)
  95. (arguments
  96. '(#:phases
  97. (modify-phases %standard-phases
  98. (replace 'check
  99. (lambda* (#:key tests? #:allow-other-keys)
  100. (when tests? (invoke "pytest"))
  101. #t)))))
  102. (inputs
  103. (list python-dateutil
  104. python-requests
  105. python-lxml
  106. python-openpyxl
  107. python-xlrd))
  108. (native-inputs
  109. (list python-pytest))
  110. (synopsis "Terminal spreadsheet multitool for discovering and arranging data")
  111. (description
  112. "VisiData is an interactive multitool for tabular data. It combines the
  113. clarity of a spreadsheet, the efficiency of the terminal, and the power of
  114. Python, into a lightweight utility which can handle millions of rows.")
  115. (home-page "https://www.visidata.org/")
  116. (license gpl3)))