12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667 |
- (define-module (gnu packages serveez)
- #:use-module (guix packages)
- #:use-module (guix licenses)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages guile))
- (define-public serveez
- (package
- (name "serveez")
- (version "0.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/serveez/serveez-"
- version ".tar.lz"))
- (sha256
- (base32
- "0capm8i6fyjvh5rflxkfd07llfaa0kk4i3y836qpld9vzy49q6ky"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags '("--enable-libserveez-install")
- #:phases
- (modify-phases %standard-phases
- (add-before 'patch-source-shebangs 'patch-test-source
- (lambda _
- (substitute*
- (find-files "test" "^t[0-9]{3}$")
- (("/bin/sh") (which "sh")))
- #t)))))
- (native-inputs
- (list lzip))
- (inputs
- (list guile-2.2))
- (home-page "https://www.gnu.org/software/serveez/")
- (synopsis "Framework for implementing IP-based servers")
- (description
- "GNU Serveez is a server framework providing the routines necessary to
- easily implement IP-based servers in your application. It
- demonstrates aspects of network programming in a portable manner,
- making it convenient for both simplifying the process of adding a
- server to your application or for learning about how network services
- work. Several example servers are provided already, such as an HTTP
- server and an IRC server.")
- (license gpl3+)))
|