serveez.scm 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages serveez)
  20. #:use-module (guix packages)
  21. #:use-module (guix licenses)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages)
  25. #:use-module (gnu packages compression)
  26. #:use-module (gnu packages guile))
  27. (define-public serveez
  28. (package
  29. (name "serveez")
  30. (version "0.3.0")
  31. (source
  32. (origin
  33. (method url-fetch)
  34. (uri (string-append "mirror://gnu/serveez/serveez-"
  35. version ".tar.lz"))
  36. (sha256
  37. (base32
  38. "0capm8i6fyjvh5rflxkfd07llfaa0kk4i3y836qpld9vzy49q6ky"))))
  39. (build-system gnu-build-system)
  40. (arguments
  41. `(#:configure-flags '("--enable-libserveez-install")
  42. #:phases
  43. (modify-phases %standard-phases
  44. (add-before 'patch-source-shebangs 'patch-test-source
  45. (lambda _
  46. (substitute*
  47. (find-files "test" "^t[0-9]{3}$")
  48. (("/bin/sh") (which "sh")))
  49. #t)))))
  50. (native-inputs
  51. (list lzip))
  52. (inputs
  53. (list guile-2.2))
  54. (home-page "https://www.gnu.org/software/serveez/")
  55. (synopsis "Framework for implementing IP-based servers")
  56. (description
  57. "GNU Serveez is a server framework providing the routines necessary to
  58. easily implement IP-based servers in your application. It
  59. demonstrates aspects of network programming in a portable manner,
  60. making it convenient for both simplifying the process of adding a
  61. server to your application or for learning about how network services
  62. work. Several example servers are provided already, such as an HTTP
  63. server and an IRC server.")
  64. (license gpl3+)))