perl-maths.scm 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages perl-maths)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system perl)
  23. #:use-module (gnu packages perl)
  24. #:use-module (gnu packages perl-check))
  25. (define-public perl-math-cephes
  26. (package
  27. (name "perl-math-cephes")
  28. (version "0.5305")
  29. (source (origin
  30. (method url-fetch)
  31. (uri (string-append
  32. "mirror://cpan/authors/id/S/SH/SHLOMIF/Math-Cephes-"
  33. version ".tar.gz"))
  34. (sha256
  35. (base32
  36. "18c3xg53d1vv7hlj43601jj7ks119fm6ndpwpv94irr2905806jn"))
  37. ;; For reproducibility
  38. (modules '((guix build utils)))
  39. (snippet
  40. '(substitute* "libmd/Makefile.PL"
  41. (("readdir DIR") "sort readdir DIR")))))
  42. (build-system perl-build-system)
  43. (home-page "https://metacpan.org/release/Math-Cephes")
  44. (synopsis "Perl interface to the Cephes math library")
  45. (description "The Math::Cephes module provides a Perl interface to over
  46. 150 functions of the Cephes math library.")
  47. (license license:perl-license)))
  48. (define-public perl-math-matrixreal
  49. (package
  50. (name "perl-math-matrixreal")
  51. (version "2.13")
  52. (source (origin
  53. (method url-fetch)
  54. (uri (string-append
  55. "mirror://cpan/authors/id/L/LE/LETO/Math-MatrixReal-"
  56. version ".tar.gz"))
  57. (sha256
  58. (base32
  59. "1cml5wqd99hm398gl8f147ccsck9v179l7a6vqjj4kfkdnja37sg"))))
  60. (build-system perl-build-system)
  61. (native-inputs
  62. (list perl-module-build perl-test-most))
  63. (home-page "https://metacpan.org/release/Math-MatrixReal")
  64. (synopsis "Manipulate NxN matrices of real numbers")
  65. (description "This package provides the @code{Math::MatrixReal} module.
  66. It implements the data type \"matrix of real numbers\" (and consequently also
  67. \"vector of real numbers\").")
  68. (license license:perl-license)))