pantheon.scm 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages pantheon)
  19. #:use-module (gnu packages cmake)
  20. #:use-module (gnu packages freedesktop)
  21. #:use-module (gnu packages gettext)
  22. #:use-module (gnu packages glib)
  23. #:use-module (gnu packages gnome)
  24. #:use-module (gnu packages gnupg)
  25. #:use-module (gnu packages gtk)
  26. #:use-module (gnu packages package-management)
  27. #:use-module (gnu packages pkg-config)
  28. #:use-module (gnu packages python)
  29. #:use-module (gnu packages xml)
  30. #:use-module (gnu packages)
  31. #:use-module (guix build-system meson)
  32. #:use-module (guix git-download)
  33. #:use-module ((guix licenses) #:prefix license:)
  34. #:use-module (guix packages)
  35. #:use-module (guix utils))
  36. (define-public granite
  37. (package
  38. (name "granite")
  39. (version "6.2.0")
  40. (source (origin
  41. (method git-fetch)
  42. (uri (git-reference
  43. (url "https://github.com/elementary/granite")
  44. (commit version)))
  45. (file-name (git-file-name name version))
  46. (sha256
  47. (base32
  48. "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
  49. (build-system meson-build-system)
  50. (arguments
  51. `(#:phases (modify-phases %standard-phases
  52. (add-after 'unpack 'disable-icon-cache
  53. (lambda _
  54. (setenv "DESTDIR" "/"))))))
  55. (inputs (list glib gtk+ libgee))
  56. (native-inputs (list gettext-minimal gobject-introspection pkg-config
  57. python vala))
  58. (home-page "https://github.com/elementary/granite")
  59. (synopsis "Library that extends GTK with common widgets and utilities")
  60. (description "Granite is a companion library for GTK+ and GLib. Among other
  61. things, it provides complex widgets and convenience functions designed for use
  62. in apps built for the Pantheon desktop.")
  63. (license license:lgpl3+)))
  64. (define-public pantheon-calculator
  65. (package
  66. (name "pantheon-calculator")
  67. (version "1.5.5")
  68. (source
  69. (origin
  70. (method git-fetch)
  71. (uri (git-reference
  72. (url "https://github.com/elementary/calculator")
  73. (commit version)))
  74. (file-name (git-file-name name version))
  75. (sha256
  76. (base32
  77. "1csxsr2c8qvl97xz9ahwn91z095nzgr0i1mbcb1spljll2sr9lkj"))))
  78. (build-system meson-build-system)
  79. (arguments
  80. `(#:glib-or-gtk? #t
  81. #:phases
  82. (modify-phases %standard-phases
  83. (add-after 'unpack 'disable-schema-cache-generation
  84. (lambda _
  85. (setenv "DESTDIR" "/")
  86. #t)))))
  87. (inputs
  88. `(("granite" ,granite)
  89. ("glib" ,glib)
  90. ("gtk" ,gtk+)
  91. ("libgee" ,libgee)))
  92. (native-inputs
  93. `(("cmake" ,cmake)
  94. ("glib:bin" ,glib "bin") ; for glib-compile-schemas
  95. ("gettext" ,gettext-minimal)
  96. ("pkg-config" ,pkg-config)
  97. ("vala" ,vala)))
  98. (home-page "https://github.com/elementary/calculator")
  99. (synopsis "Desktop calculator")
  100. (description "Calculator is an application for performing simple
  101. arithmetic. It is the default calculator application in the Pantheon
  102. desktop.")
  103. (license license:gpl3)))
  104. (define-public sideload
  105. (package
  106. (name "sideload")
  107. (version "6.0.2")
  108. (source
  109. (origin
  110. (method git-fetch)
  111. (uri (git-reference
  112. (url "https://github.com/elementary/sideload")
  113. (commit version)))
  114. (file-name (git-file-name name version))
  115. (sha256
  116. (base32
  117. "0abpcawmmv5mgzk2i5n9rlairmjr2v9rg9b8c9g7xa085s496bi9"))))
  118. (build-system meson-build-system)
  119. (arguments
  120. `(#:glib-or-gtk? #t
  121. #:phases
  122. (modify-phases %standard-phases
  123. (add-before 'install 'set-environment-variables
  124. (lambda _
  125. ;; Disable compiling schemas and updating desktop databases
  126. (setenv "DESTDIR" "/")))
  127. (add-after 'install 'install-symlinks
  128. (lambda* (#:key outputs #:allow-other-keys)
  129. (let* ((out (assoc-ref outputs "out"))
  130. (bin (string-append out "/bin/io.elementary.sideload"))
  131. (link (string-append out "/bin/sideload")))
  132. (symlink bin link)))))))
  133. (inputs
  134. `(("flatpak" ,flatpak)
  135. ("glib" ,glib)
  136. ("granite" ,granite)
  137. ("gtk" ,gtk+)
  138. ("hicolor-icon-theme" ,hicolor-icon-theme)
  139. ("libgee" ,libgee)
  140. ("libhandy" ,libhandy)
  141. ("libostree" ,libostree)
  142. ("libxml2" ,libxml2)))
  143. (propagated-inputs
  144. ;; Sideload needs these in the environment to fetch data securely from
  145. ;; Flatpak remotes.
  146. (list gnupg gpgme))
  147. (native-inputs
  148. `(("gettext" ,gettext-minimal)
  149. ("glib:bin" ,glib "bin")
  150. ("gobject-introspection" ,gobject-introspection)
  151. ("pkg-config" ,pkg-config)
  152. ("vala" ,vala)))
  153. (home-page "https://github.com/elementary/sideload")
  154. (synopsis "Graphical application to side-load Flatpaks")
  155. (description "Sideload handles flatpakref files, like those you might find
  156. on Flathub or another third-party website providing a Flatpak app for
  157. download.")
  158. (license license:gpl3+)))