openbox.scm 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2017 Nikita <nikita@n0.is>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages openbox)
  21. #:use-module ((guix licenses) #:select (gpl2+))
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix utils)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (gnu packages freedesktop)
  27. #:use-module (gnu packages gettext)
  28. #:use-module (gnu packages gnome)
  29. #:use-module (gnu packages gtk)
  30. #:use-module (gnu packages image)
  31. #:use-module (gnu packages pkg-config)
  32. #:use-module (gnu packages python)
  33. #:use-module (gnu packages xdisorg)
  34. #:use-module (gnu packages xml)
  35. #:use-module (gnu packages xorg))
  36. (define-public openbox
  37. (package
  38. (name "openbox")
  39. (version "3.6.1")
  40. (source (origin
  41. (method url-fetch)
  42. (uri (string-append
  43. "http://openbox.org/dist/openbox/" name "-"
  44. version ".tar.xz"))
  45. (sha256
  46. (base32
  47. "0vg2y1qddsdxkjv806mzpvmkgzliab8ll4s7zm7ma5jnriamirxb"))))
  48. (build-system gnu-build-system)
  49. (native-inputs (list pkg-config))
  50. (propagated-inputs (list python2-pyxdg))
  51. (inputs (list imlib2
  52. libxml2
  53. (librsvg-for-system)
  54. libsm
  55. libxcursor
  56. libxinerama
  57. libxml2
  58. libxrandr
  59. libxft
  60. pango
  61. python-2))
  62. (synopsis "Box style window manager")
  63. (description
  64. "Openbox is a highly configurable, next generation window manager with
  65. extensive standards support. The *box visual style is well known for its
  66. minimalistic appearance. Openbox uses the *box visual style, while providing
  67. a greater number of options for theme developers than previous *box
  68. implementations.")
  69. (home-page "http://openbox.org/wiki/Main_Page")
  70. (license gpl2+)))
  71. (define-public obconf
  72. (package
  73. (name "obconf")
  74. (version "2.0.4")
  75. (source
  76. (origin
  77. (method url-fetch)
  78. (uri (string-append "http://openbox.org/dist/" name
  79. "/" name "-" version ".tar.gz"))
  80. (sha256
  81. (base32
  82. "1fanjdmd8727kk74x5404vi8v7s4kpq48l583d12fsi4xvsfb8vi"))))
  83. (inputs
  84. `(("gtk+-2" ,gtk+-2)
  85. ("imlib2" ,imlib2)
  86. ("libglade" ,libglade)
  87. ("openbox" ,openbox)
  88. ("startup-notification" ,startup-notification)
  89. ("libsm" ,libsm)
  90. ("librsvg" ,librsvg)
  91. ("libxft" ,libxft)))
  92. (native-inputs
  93. `(("gettext" ,gettext-minimal)
  94. ("pkg-config" ,pkg-config)))
  95. (build-system gnu-build-system)
  96. (arguments
  97. `(#:configure-flags (list "--enable-nls")))
  98. (home-page "http://openbox.org/wiki/ObConf:About")
  99. (synopsis "Openbox configuration tool")
  100. (description
  101. "Obconf is a tool for configuring the Openbox window manager.
  102. You can configure its appearance, themes, and much more.")
  103. (license gpl2+)))
  104. ;;; openbox.scm ends here