123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176 |
- (define-module (gnu packages mono)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (gnu packages fontutils)
- #:use-module (gnu packages gettext)
- #:use-module (gnu packages glib)
- #:use-module (gnu packages gtk)
- #:use-module (gnu packages image)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages photo)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages python)
- #:use-module (gnu packages xml)
- #:use-module (gnu packages)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix git-download)
- #:use-module (guix build-system gnu))
- (define-public mono
- (package
- (name "mono")
- (version "4.4.1.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://download.mono-project.com/sources/mono/"
- name "-" version
- ".tar.bz2"))
- (sha256
- (base32
- "0jibyvyv2jy8dq5ij0j00iq3v74r0y90dcjc3dkspcfbnn37cphn"))
- (patches (search-patches "mono-mdoc-timestamping.patch"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib" ,glib)
- ("libxslt" ,libxslt)
- ("perl" ,perl)
- ("python" ,python-2)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-reproducible
- (lambda _
- (substitute* "mono/mini/Makefile.in"
- (("build_date = [^;]*;")
- "build_date = (void*) 0;"))
- #t))
- (add-after 'unpack 'set-env
- (lambda _
-
- (setenv "HOME" "/tmp")
-
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- #t))
- (add-after 'unpack 'fix-includes
- (lambda _
-
- (substitute* "mono/io-layer/processes.c"
- (("#ifdef HAVE_SYS_MKDEV_H") "#if 1")
- (("sys/mkdev.h") "sys/sysmacros.h"))
- #t))
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* "mono/tests/Makefile.in"
-
- (("@test-unhandled-exception-2:" all)
- (string-append all "#")))
- (substitute* "mcs/tools/mono-symbolicate/Makefile"
-
-
- (("^check: test-local") "check:\ntest-local:")
- (("^test-local: all") "disabled-test-local:"))
- (substitute* "mono/unit-tests/Makefile.in"
-
- (("^test-sgen-qsort.log:")
- "disabled-test-sgen-qsort.log:\ntest-sgen-qsort.log:"))
-
- (substitute* "mcs/class/Makefile"
- (("^include ../build/rules.make" all)
- (string-append
- all
- "\nrun-test-recursive:\n\t@echo skipping tests\n")))
-
- (substitute* "mcs/class/Microsoft.Build.Tasks/Makefile"
- (("^include ../../build/rules.make" all)
- (string-append
- all
- "\nrun-test-recursive:\n\t@echo skipping tests\n")))
- (substitute* '("mcs/tools/mono-shlib-cop/Makefile"
- "mcs/tools/mdoc/Makefile")
- (("^run-test-local:" all)
- (string-append "#" all)))
- (substitute* "mcs/tools/sqlmetal/Makefile"
- (("^include ../../build/rules.make" all)
- (string-append
- "NO_TEST:=true\n"
- all
- "\nrun-test-lib:\n\t@echo skipping test\n"))))))
-
- #:make-flags `(,(string-append "PLATFORM_DISABLED_TESTS="
- " appdomain-unload.exe"
- " delegate2.exe"
- " finally_guard.exe"
- " remoting4.exe"))
-
- #:parallel-tests? #f))
- (synopsis "Compiler and libraries for the C# programming language")
- (description "Mono is a compiler, vm, debugger and set of libraries for
- C#, a C-style programming language from Microsoft that is very similar to
- Java.")
- (home-page "https://www.mono-project.com/")
- (license license:x11)))
- (define-public libgdiplus
- (package
- (name "libgdiplus")
- (version "6.0.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://download.mono-project.com/sources/libgdiplus/libgdiplus-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "1vr5l09i5i91n9qzky7ab9wwvgdidvrbw26y8llip0z4qdf4w7mq"))))
- (build-system gnu-build-system)
- (native-inputs
- (list pkg-config))
- (inputs
- `(("glib" ,glib)
- ("cairo" ,cairo)
- ("fontconfig" ,fontconfig)
- ("libtiff" ,libtiff)
- ("libjpeg" ,libjpeg-turbo)
- ("libexif" ,libexif)
- ("libungif" ,libungif)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
-
-
- (add-before 'configure 'remove-buggy-tests
- (lambda _
- (substitute* "tests/Makefile.in"
- (("testicocodec\\$\\(EXEEXT\\) ") " ")
- (("testfont\\$\\(EXEEXT\\) ") " "))
- #t)))))
- (home-page "https://www.mono-project.com/docs/gui/libgdiplus/")
- (synopsis "Mono library that provides a GDI+-compatible API")
- (description "Libgdiplus is the Mono library that provides a
- GDI+-compatible API on non-Windows operating systems. The implementation uses
- Cairo to do most of the heavy lifting.")
- (license license:gpl3+)))
|