libftdi.scm 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages libftdi)
  20. #:use-module (guix licenses)
  21. #:use-module (guix download)
  22. #:use-module (guix packages)
  23. #:use-module (gnu packages)
  24. #:use-module (gnu packages libusb)
  25. #:use-module (guix build-system cmake))
  26. (define-public libftdi
  27. (package
  28. (name "libftdi")
  29. (version "1.4")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append
  33. "http://www.intra2net.com/en/developer/libftdi/download/libftdi1-"
  34. version ".tar.bz2"))
  35. (sha256
  36. (base32
  37. "0x0vncf6i92slgrn0h7ghkskqbglbs534220qa84d0qg114zndpc"))))
  38. (build-system cmake-build-system)
  39. (propagated-inputs
  40. (list libusb)) ; required by libftdi1.pc
  41. (home-page "https://www.intra2net.com/en/developer/libftdi/")
  42. (synopsis "FTDI USB driver with bitbang mode")
  43. (description
  44. "libFTDI is a library to talk to FTDI chips: FT232BM,
  45. FT245BM, FT2232C, FT2232D, FT245R and FT232H including the popular
  46. bitbangmode.")
  47. (license lgpl2.1)))