dunst.scm 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015, 2017, 2018 Alex Kost <alezost@gmail.com>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
  5. ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
  6. ;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
  7. ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
  8. ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
  9. ;;;
  10. ;;; This file is part of GNU Guix.
  11. ;;;
  12. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  13. ;;; under the terms of the GNU General Public License as published by
  14. ;;; the Free Software Foundation; either version 3 of the License, or (at
  15. ;;; your option) any later version.
  16. ;;;
  17. ;;; GNU Guix is distributed in the hope that it will be useful, but
  18. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  19. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  20. ;;; GNU General Public License for more details.
  21. ;;;
  22. ;;; You should have received a copy of the GNU General Public License
  23. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  24. (define-module (gnu packages dunst)
  25. #:use-module (guix packages)
  26. #:use-module (guix git-download)
  27. #:use-module (guix build-system gnu)
  28. #:use-module (guix utils)
  29. #:use-module ((guix licenses) #:prefix license:)
  30. #:use-module (gnu packages)
  31. #:use-module (gnu packages base)
  32. #:use-module (gnu packages freedesktop)
  33. #:use-module (gnu packages glib)
  34. #:use-module (gnu packages gnome)
  35. #:use-module (gnu packages gtk)
  36. #:use-module (gnu packages perl)
  37. #:use-module (gnu packages pkg-config)
  38. #:use-module (gnu packages xorg))
  39. (define-public dunst
  40. (package
  41. (name "dunst")
  42. (version "1.8.1")
  43. (source (origin
  44. (method git-fetch)
  45. (uri (git-reference
  46. (url "https://github.com/dunst-project/dunst")
  47. (commit (string-append "v" version))))
  48. (file-name (git-file-name name version))
  49. (sha256
  50. (base32
  51. "19bh5789whlc0n5wbyx3yx8px93hccn42f1p6i1dz96hdkk5mjb8"))))
  52. (build-system gnu-build-system)
  53. (arguments
  54. `(#:tests? #f ; no check target
  55. #:make-flags (list (string-append "CC=" ,(cc-for-target))
  56. (string-append "PREFIX=" %output)
  57. (string-append "SYSCONFDIR=" %output "/etc")
  58. ;; Otherwise it tries to install service file
  59. ;; to "dbus" store directory.
  60. (string-append "SERVICEDIR_DBUS=" %output
  61. "/share/dbus-1/services")
  62. "dunstify")
  63. #:phases (modify-phases %standard-phases
  64. (delete 'configure))))
  65. (native-inputs
  66. (list pkg-config perl ; for pod2man
  67. which))
  68. (inputs
  69. (list dbus
  70. librsvg ; for svg support
  71. glib
  72. cairo
  73. pango
  74. libnotify ; for dunstify
  75. libx11
  76. libxscrnsaver
  77. libxinerama
  78. libxrandr
  79. libxdg-basedir
  80. wayland)) ; for wayland support
  81. (home-page "https://dunst-project.org/")
  82. (synopsis "Customizable and lightweight notification daemon")
  83. (description
  84. "Dunst is a highly configurable and minimalistic notification daemon.
  85. It provides @code{org.freedesktop.Notifications} D-Bus service, so it is
  86. started automatically on the first call via D-Bus.")
  87. (license license:bsd-3)))