cyrus-sasl.scm 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
  4. ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
  5. ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages cyrus-sasl)
  22. #:use-module (gnu packages)
  23. #:use-module (gnu packages autotools)
  24. #:use-module (gnu packages dbm)
  25. #:use-module (gnu packages kerberos)
  26. #:use-module (gnu packages tls)
  27. #:use-module ((guix licenses) #:prefix license:)
  28. #:use-module (guix packages)
  29. #:use-module (guix download)
  30. #:use-module (guix build-system gnu))
  31. (define-public cyrus-sasl
  32. (package
  33. (name "cyrus-sasl")
  34. (version "2.1.27")
  35. (source (origin
  36. (method url-fetch)
  37. (uri (list (string-append
  38. "https://cyrusimap.org/releases/cyrus-sasl-"
  39. version ".tar.gz")
  40. (string-append
  41. "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
  42. version ".tar.gz")))
  43. (sha256 (base32
  44. "1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
  45. (patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"
  46. "cyrus-sasl-CVE-2019-19906.patch"))))
  47. (build-system gnu-build-system)
  48. (native-inputs
  49. (list autoconf automake libtool))
  50. (inputs (list gdbm openssl))
  51. (propagated-inputs
  52. (list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
  53. mit-krb5))
  54. (arguments
  55. '(#:configure-flags (list (string-append "--with-plugindir="
  56. (assoc-ref %outputs "out")
  57. "/lib/sasl2"))
  58. ;; The 'plugins' directory has shared source files, such as
  59. ;; 'plugin_common.c'. When building the shared libraries there, libtool
  60. ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
  61. ;; fail with EEXIST when building things in parallel.
  62. #:parallel-build? #f
  63. #:phases
  64. (modify-phases %standard-phases
  65. (add-after 'unpack 'autogen
  66. (lambda _
  67. (invoke "autoreconf" "-vif"))))))
  68. (synopsis "Simple Authentication Security Layer implementation")
  69. (description
  70. "SASL (Simple Authentication Security Layer) is an Internet
  71. standards-track method for remote computers to authenticate. The Cyrus SASL
  72. library makes supporting various SASL mechanisms easy for both client and
  73. server writers.")
  74. (license (license:non-copyleft "file://COPYING"
  75. "See COPYING in the distribution."))
  76. (home-page "https://cyrusimap.org/sasl/")))