xnee.scm 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages xnee)
  20. #:use-module (guix packages)
  21. #:use-module (guix licenses)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages gtk)
  25. #:use-module (gnu packages pkg-config)
  26. #:use-module (gnu packages xorg))
  27. (define-public xnee
  28. (package
  29. (name "xnee")
  30. (version "3.19")
  31. (source (origin
  32. (method url-fetch)
  33. (uri (string-append "mirror://gnu/xnee/xnee-"
  34. version ".tar.gz"))
  35. (sha256
  36. (base32
  37. "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j"))))
  38. (build-system gnu-build-system)
  39. (inputs
  40. `(("gtk+" ,gtk+-2)
  41. ("libx11" ,libx11)
  42. ("libxext" ,libxext)
  43. ("libxi" ,libxi)
  44. ("libxtst" ,libxtst)
  45. ("xorgproto" ,xorgproto)))
  46. (native-inputs
  47. `(("pkg-config" ,pkg-config)))
  48. (home-page "https://www.gnu.org/software/xnee/")
  49. (synopsis "Record, replay and distribute user actions under X11")
  50. (description
  51. "GNU Xnee is a program that can record, replay and distribute user
  52. actions in X11. It can be used to automate user interactions for testing or
  53. demonstration purposes.")
  54. (license gpl3+)))