wv.scm 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
  3. ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
  4. ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages wv)
  21. #:use-module (gnu packages)
  22. #:use-module (gnu packages compression)
  23. #:use-module (gnu packages glib)
  24. #:use-module (gnu packages gnome)
  25. #:use-module (gnu packages image)
  26. #:use-module (gnu packages pkg-config)
  27. #:use-module (guix packages)
  28. #:use-module (guix download)
  29. #:use-module (guix build-system gnu)
  30. #:use-module ((guix licenses) #:prefix license:))
  31. (define-public wv
  32. (package
  33. (name "wv")
  34. (version "1.2.9")
  35. (source
  36. (origin
  37. (method url-fetch)
  38. (uri (string-append "https://abiword.org/downloads/wv/"
  39. version "/wv-" version ".tar.gz"))
  40. (sha256
  41. (base32 "17f16lkdv1c3amaz2hagiicih59ynpp4786k1m2qa1sw68xhswsc"))))
  42. (build-system gnu-build-system)
  43. (inputs
  44. `(("glib" ,glib)
  45. ("libgsf" ,libgsf)
  46. ("libjpeg" ,libjpeg-turbo)
  47. ("libpng" ,libpng)
  48. ("zlib" ,zlib)))
  49. (native-inputs
  50. `(("glib" ,glib "bin")
  51. ("pkg-config" ,pkg-config)))
  52. (synopsis "Microsoft Word conversion library and utilities")
  53. (description
  54. "wv converts files written by Word 2000, 97, 95, and 6 (known internally as
  55. Word 9, 8, 7, and 6) to HTML or LaTeX. Word 2 documents can still be converted
  56. to plain text but will lack formatting.
  57. Other programs can use wv as a library to convert Word documents to other
  58. formats. AbiWord uses it as its Word importer, and KWord uses concepts and
  59. code from wv in theirs.")
  60. (home-page "http://wvware.sourceforge.net/")
  61. (license license:gpl2+)))